Bug 1295621 - [Docs] [CLI] Generate the CLI Guide
[Docs] [CLI] Generate the CLI Guide
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Radek Bíba
Don Domingo
: Documentation
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-04 22:27 EST by Andrew Dahms
Modified: 2016-04-13 00:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-13 00:45:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Dahms 2016-01-04 22:27:56 EST
The content for the CLI Guide must be generated for Red Hat Enterprise Linux OpenStack Platform 8.
Comment 2 Andrew Dahms 2016-01-07 00:48:19 EST
Assigning to Radek for review.

Radek - see the instructions for how to generate this guide, but feel free to reach out to Don or myself if you run into any issues along the way!
Comment 5 Don Domingo 2016-02-09 21:25:59 EST
A couple of issues:

* The title of the Gnocchi section. In https://wiki.openstack.org/wiki/Gnocchi, the project is referred to as "TDBaaS (Time Series Database as a Service)".

* In the TOC, "Image service command-line client" is Chapter 8, and the next chapter is "Image Service property keys", which is Chapter 10. If you click on the TOC link to the latter, it takes you to "Chapter 9. Image Service property keys", which is followed by a "Chapter 10. Image Service property keys" that looks like it has identical content.

I suspect that the second one is a build issue, but I thought to point it out anyway.
Comment 6 Radek Bíba 2016-02-10 02:49:23 EST
(In reply to Don Domingo from comment #5)
> A couple of issues:
> 
> * The title of the Gnocchi section. In
> https://wiki.openstack.org/wiki/Gnocchi, the project is referred to as
> "TDBaaS (Time Series Database as a Service)".

The original title is hard coded in os_doc_tools/resources/clients.yaml. I've changed it in the XML, but it should probably be changed in the code as well.

> * In the TOC, "Image service command-line client" is Chapter 8, and the next
> chapter is "Image Service property keys", which is Chapter 10. If you click
> on the TOC link to the latter, it takes you to "Chapter 9. Image Service
> property keys", which is followed by a "Chapter 10. Image Service property
> keys" that looks like it has identical content.
> 
> I suspect that the second one is a build issue, but I thought to point it
> out anyway.

The problem was partly here:

 doc-CLI_Reference]$ grep -r ch_cli_glance_property_keys.xml en-US/
en-US/bk-cli-reference.xml:    <xi:include href="ch_cli_glance_property_keys.xml"/>
en-US/autogen/ch_cli_glance_commands.xml:    <xi:include href="../ch_cli_glance_property_keys.xml"/>

And partly the fact that it was a chapter. I converted it into a section (8.5 under Glance) and disabled the double inclusion of the file:

https://gitlab.cee.redhat.com/rhci-documentation/docs-Red_Hat_Enterprise_Linux_OpenStack_Platform/commit/111c2f91922e160c06c96ac16588cd84b6fd20b8

Please reload http://lacrosse.corp.redhat.com/~rbiba/doc-preview/docs-Red_Hat_Enterprise_Linux_OpenStack_Platform/doc-CLI_Reference/ to get the new revision.

Is that better?

Thanks!
Comment 7 Don Domingo 2016-02-10 05:25:19 EST
That looks better, I don't see any further problems with the doc.
Comment 8 Andrew Dahms 2016-04-13 00:45:26 EDT
This content is now live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.