Bug 129564 - RFE: User-Understandable Default folders in Home Directory
RFE: User-Understandable Default folders in Home Directory
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-10 09:16 EDT by Stewart Smith
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-24 03:23:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example screenshot of home directory (29.83 KB, image/png)
2004-08-10 09:52 EDT, Stewart Smith
no flags Details

  None (edit)
Description Stewart Smith 2004-08-10 09:16:58 EDT
I propose adding the following to the /etc/skel for new users, with
funky icons on the folders to help increasing the clarity of where
things are and some hints on helping them organise things.

Note that with the introduction of things like ~/Contacts/, ~/Mail/
and ~/Settings, this gives the user a clear picture of where things
are, and what things are important to back up (if they so choose).

Some users may just see their mail as important, and not care about
contacts or music. Others may see Contacts, Mail, Settings and
Documents as important and can just (easily! with nautilus-cd-burner)
write these to CD for backup.

~/Contacts - where evolution stores contacts, with human-readable file
names (e.g. "Firstname Lastname.vcf" or something).
~/Desktop - same as it is now, the contents of the users desktop.
~/Documents - a suggested location for documents (and the default save
location for applications such as OpenOffice)
~/Mail - where Evolution stores it's mail.
~/Movies - for the kick-ass iMovie type thing that we so need.
~/Music - Music Player's place to put music!
~/Photos - Gthumb's place to go, and the digital camera tool!
~/Web Pages - ==public_html (and shared by apache, if installed).

I have no real expectation taht this will make Core3 in any complete
way, but is a good talking point and UI suggestion. This will make it
easier for users.
Comment 1 Stewart Smith 2004-08-10 09:52:28 EDT
Created attachment 102565 [details]
Example screenshot of home directory
Comment 2 Bryan W Clark 2004-08-10 13:00:41 EDT
This idea has some merit in the direction that we're trying to head. 
In our Brave New World (tm) we're aiming to create first class objects
out of some of these types.  While creating these directories provides
a nice initial layout it forces people into an organization strategy
that might not be optimal.  A simple example can be seen with digital
photos/movies.  

Most digital cameras offer the ability to capture small movies as well
as take pictures.  When you import these pictures, the movies and
pictures should probably all remain together under an album or some
kind of categorization.  With the directory separation of Movies and
Photos, the small movies that were taken along with the pictures would
be separated into different folders when they have the most relation
to each other as a group and not really to their media type.
Comment 3 Jones Lee 2004-08-11 02:40:41 EDT
I love this idea, it makes life easier for normal users.
Comment 4 Mark McLoughlin 2004-08-11 03:23:10 EDT
Along the lines of what Bryan said, I'm not sure suggesting such an
arbitrary organisation to people will really help people. It feels
completely arbitrary - do we have any reason to believe that this is a
natural orginisation method?

The obvious big problem with any directories like this is
internationalisation - we have no defined method for handling that
right now.

Finally, I don't think its very useful to keep a bug open on this (but
I won't close it). We probably will only ever do this if we do it
upstream first, so to really help see this through to fruition it
would be a lot more useful to start talking about this upstream
(xdg-list would be a good start)
Comment 5 Stewart Smith 2004-08-11 09:01:43 EDT
I'll take it upstream and see what people thing.

Although there is a problem seperating Photos and Movies, possibly
some naming like "My Multimedia" or "Multimedia" or something could
help remove the ambiguity(?).

It has been suggested that it also be taken to xdg list (at
freedesktop.org) - will do this shortly.
Comment 6 Mark McLoughlin 2004-09-23 11:59:22 EDT
Okay, moving to nautilus anyway - it doesn't have any relevance to the
gnome-desktop package.
Comment 7 Alexander Larsson 2004-09-24 03:23:11 EDT
Its not really a nautilus bug either.
I know there has been lots of discussion on things like this upstream,
we're well aware of the need of this. I am however gonna close this
bug, because its not contributing to the upstream solution, its only
making it hard to find real bugs in bugzilla atm.

However, don't be discouraged from working on this upstream.
(Although, don't expect things to happen immediately, these things
take time.)

Note You need to log in before you can comment on or make changes to this bug.