Bug 1295642 - <reservesys/> is silently discarded from job XML
<reservesys/> is silently discarded from job XML
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: general (Show other bugs)
develop
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 22.0
: ---
Assigned To: Dan Callaghan
tools-bugs
: Patch, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 00:29 EST by Dan Callaghan
Modified: 2016-01-14 00:33 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-14 00:33:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2016-01-05 00:29:13 EST
Description of problem:
<reservesys/> is silently discarded from job XML.

Version-Release number of selected component (if applicable):
22.0rc1 (does not affect any released version)

How reproducible:
easily

Steps to Reproduce:
1. Submit a job which uses <reservesys/> after the <task/> elements in the <recipe/>
(see https://beaker-project.org/docs/user-guide/system-reservation.html#using-the-reservesys-element)

Actual results:
Beaker does not reserve the system at the end of the recipe.
If you clone the job, the <reservesys/> element is missing.

Expected results:
Beaker should reserve the system at the end of the recipe.
The <reservesys/> element should be preserved when the job is cloned.

Additional info:
Regression in recipe XML parsing due to the lxml conversion. <reservesys/> is missing from complete-job.xml so parsing of <reservesys/> is not covered by any tests.
Comment 1 Dan Callaghan 2016-01-05 00:50:33 EST
http://gerrit.beaker-project.org/4563
Comment 5 Dan Callaghan 2016-01-14 00:33:18 EST
Beaker 22.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.