Bug 1295659 - The title of remote-viewer window is incorrect when open a vm in RHEVM
The title of remote-viewer window is incorrect when open a vm in RHEVM
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Unspecified
medium Severity medium
: ovirt-3.6.3
: 3.6.3
Assigned To: Marek Libra
Ilanit Stein
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 01:59 EST by xiaodwan
Modified: 2016-03-21 09:03 EDT (History)
20 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The release cursor key combination that is displayed in the title of a virtual machine's remote viewer no longer shows incorrect key combinations.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 09:03:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 51634 master MERGED webadmin: Release keys removed from the console title 2016-01-27 04:34 EST
oVirt gerrit 52807 ovirt-engine-3.6 MERGED webadmin: Release keys removed from the console title 2016-01-28 03:02 EST
oVirt gerrit 52862 ovirt-engine-3.6.3 MERGED webadmin: Release keys removed from the console title 2016-01-30 17:48 EST

  None (edit)
Description xiaodwan 2016-01-05 01:59:26 EST
Description of problem:
The title of remote-viewer window is incorrect when open a vm in RHEVM

Version-Release number of selected component (if applicable):
virt-viewer-2.0-10.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Login RHEVM.
2. Click "Virtual machines" tab and select one vm.
3. Click console button and save the console.vv file to local.
4. Modify the shortcuts of "release-cursor=shift+f12" to "release-cursor=ctrl+alt" in console.vv.
5. Run "remote-viewer console.vv".

Actual results:
The title is "$guestname - Press SHIFT+F12 to Release Cursor - Remote Viewer".

Expected results:
The shortcut should be consistent with that in console.vv or just remove the shortcut description because the correct way to release pointer can be displayed in parentheses when the mouse is captured.

Additional info:
Comment 2 Pavel Grunt 2016-01-05 02:12:05 EST
(In reply to xiaodwan from comment #0)
> Description of problem:
> The title of remote-viewer window is incorrect when open a vm in RHEVM
> 
> Version-Release number of selected component (if applicable):
> virt-viewer-2.0-10.el6.x86_64
> 
> How reproducible:
> 100%
> 
> Steps to Reproduce:
> 1. Login RHEVM.
> 2. Click "Virtual machines" tab and select one vm.
> 3. Click console button and save the console.vv file to local.
> 4. Modify the shortcuts of "release-cursor=shift+f12" to
> "release-cursor=ctrl+alt" in console.vv.
> 5. Run "remote-viewer console.vv".
> 
> Actual results:
> The title is "$guestname - Press SHIFT+F12 to Release Cursor - Remote
> Viewer".
> 

check the content of the vv file, there is the 'title' key. virt-viewer just uses its value as the title. We can do nothing about it from the virt-viewer's side.

> Expected results:
> The shortcut should be consistent with that in console.vv or just remove the
> shortcut description because the correct way to release pointer can be
> displayed in parentheses when the mouse is captured.
> 
> Additional info:
Comment 3 Fabiano Fidêncio 2016-01-05 03:16:15 EST
(In reply to Pavel Grunt from comment #2)
> (In reply to xiaodwan from comment #0)
> > Description of problem:
> > The title of remote-viewer window is incorrect when open a vm in RHEVM
> > 
> > Version-Release number of selected component (if applicable):
> > virt-viewer-2.0-10.el6.x86_64
> > 
> > How reproducible:
> > 100%
> > 
> > Steps to Reproduce:
> > 1. Login RHEVM.
> > 2. Click "Virtual machines" tab and select one vm.
> > 3. Click console button and save the console.vv file to local.
> > 4. Modify the shortcuts of "release-cursor=shift+f12" to
> > "release-cursor=ctrl+alt" in console.vv.
> > 5. Run "remote-viewer console.vv".
> > 
> > Actual results:
> > The title is "$guestname - Press SHIFT+F12 to Release Cursor - Remote
> > Viewer".
> > 
> 
> check the content of the vv file, there is the 'title' key. virt-viewer just
> uses its value as the title. We can do nothing about it from the
> virt-viewer's side.

Is worth to mention that having it in the title nowadays is useless, as when the mouse is grabbed the title is already update with the message "Press %s to release the pointer", this one showing the proper shortcut. So, in the end the users see the message twice, and one of them is wrong :-\

My suggestion is just to move this bug to the part responsible for creating the .vv file (RHEVM ?) and ask then to remove the hard-coded "Press SHIFT+F12 to Release Cursor" string,
Comment 4 Fabiano Fidêncio 2016-01-05 03:18:48 EST
Re-assigning the bug to the right (?) component.
Comment 5 Michal Skrivanek 2016-01-08 12:18:28 EST
good one:)
Since when does the client show the measage on its own? We don't want to remove it for not-so-old clients I guess
Comment 7 Fabiano Fidêncio 2016-01-11 02:11:36 EST
(In reply to Michal Skrivanek from comment #5)
> good one:)
> Since when does the client show the measage on its own? We don't want to
> remove it for not-so-old clients I guess

Michal,

virt-viewer started properly handling that on commit 7ffd3d4f7e513cb729264d545a6ffb66560f74bc (v0.5.3), which is included on virt-viewer builds since rhel-6.4.
Comment 8 Michal Skrivanek 2016-01-11 05:41:58 EST
(In reply to Fabiano Fidêncio from comment #7)
> (In reply to Michal Skrivanek from comment #5)
> > good one:)
> > Since when does the client show the measage on its own? We don't want to
> > remove it for not-so-old clients I guess
> 
> Michal,
> 
> virt-viewer started properly handling that on commit
> 7ffd3d4f7e513cb729264d545a6ffb66560f74bc (v0.5.3), which is included on
> virt-viewer builds since rhel-6.4.

That's good news, thank you for the confirmation
Comment 9 Michal Skrivanek 2016-01-11 05:43:21 EST
note that there is no bug in the string itself, it is created dynamically based on the mapping in RHEV-M. You are not supposed to change it in the .vv file (you're not supposed to modify it at all - and if you do, then you could change the string as well)
Comment 10 Michal Skrivanek 2016-01-11 05:52:36 EST
we can easily drop it
also, though unrelated - the generated file is not ended with a newline
Comment 11 Fabiano Fidêncio 2016-01-11 05:58:09 EST
(In reply to Michal Skrivanek from comment #9)
> note that there is no bug in the string itself, it is created dynamically
> based on the mapping in RHEV-M. You are not supposed to change it in the .vv
> file (you're not supposed to modify it at all - and if you do, then you
> could change the string as well)

I am kinda fine about closing it as a WONTFIX, tbh.
It was opened by virt-qa and the way they were testing was changing the hotkeys after download the .vv file. I don't think that's what a user should do.

Anyways, dropping seems okay as well, mainly because we have redundant information in the title.
Comment 12 Ilanit Stein 2016-02-18 07:22:36 EST
Verified on rhevm 3.6.3.2-0.1.

In console.vv file, 
title=<vm name>:%d - Press SHIFT+F12 to Release Cursor
changed to title=<vm name>:%d
Comment 13 Eyal Edri 2016-03-21 09:03:33 EDT
3.6.3 was GA, closing

Note You need to log in before you can comment on or make changes to this bug.