Bug 1295663 - dialyzer --build_plt crashes
Summary: dialyzer --build_plt crashes
Keywords:
Status: CLOSED DUPLICATE of bug 1456567
Alias: None
Product: Fedora
Classification: Fedora
Component: erlang
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-05 07:13 UTC by Randy Barlow
Modified: 2018-09-20 12:34 UTC (History)
6 users (show)

Fixed In Version: erlang-19.1.6-2.fc25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-07 05:24:09 UTC


Attachments (Terms of Use)
erl_crash.dump (705.48 KB, text/plain)
2016-01-05 07:13 UTC, Randy Barlow
no flags Details

Description Randy Barlow 2016-01-05 07:13:31 UTC
Created attachment 1111752 [details]
erl_crash.dump

Description of problem:
When I try to build a PLT, dialyzer crashes.


Version-Release number of selected component (if applicable):
$ rpm -q erlang-dialyzer
erlang-dialyzer-17.4-5.fc24.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. $ dialyzer --build_plt --apps erts kernel stdlib

Actual results:
$ dialyzer --build_plt --apps erts kernel stdlib
  Compiling some key modules to native code...{"init terminating in do_boot",{{badmatch,{error,{'EXIT',{badarg,[{hipe_bifs,patch_call,[1095479243,94032498909904,[]],[]},{hipe_unified_loader,patch_call_insn,3,[{file,"hipe_unified_loader.erl"},{line,507}]},{hipe_unified_loader,patch_bif_call_list,4,[{file,"hipe_unified_loader.erl"},{line,492}]},{hipe_unified_loader,patch_call,5,[{file,"hipe_unified_loader.erl"},{line,483}]},{hipe_unified_loader,patch,5,[{file,"hipe_unified_loader.erl"},{line,458}]},{hipe_unified_loader,load_common,4,[{file,"hipe_unified_loader.erl"},{line,235}]},{hipe_unified_loader,load_module,3,[{file,"hipe_unified_loader.erl"},{line,156}]},{code_server,handle_call,3,[{file,"code_server.erl"},{line,332}]}]}}}},[{hipe,finalize,5,[{file,"hipe.erl"},{line,751}]},{hipe,compile_finish,3,[{file,"hipe.erl"},{line,708}]},{hipe,'-run_compiler_1/3-fun-0-',4,[{file,"hipe.erl"},{line,669}]}]}}

Crash dump was written to: erl_crash.dump
init terminating in do_boot ()

Expected results:
Successful build.

Additional info:
I've attached the erl_crash.dump file.

Comment 1 Jan Kurik 2016-02-24 15:33:03 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase

Comment 2 Johannes W 2016-11-05 13:16:26 UTC
This also affects Fedora 25, specifically package erlang19.1.4-1.fc25. HiPE (which Dialyzer uses) is broken when Erlang is compiled as position-independent executable. See my upstream bug report:
https://bugs.erlang.org/browse/ERL-294

Comment 3 Fedora Update System 2016-11-26 21:13:31 UTC
erlang-19.1.6-2.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-cabc4340f0

Comment 4 Fedora Update System 2016-11-27 23:00:21 UTC
erlang-19.1.6-2.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-cabc4340f0

Comment 5 Fedora Update System 2016-12-07 05:24:09 UTC
erlang-19.1.6-2.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Peter Lemenkov 2018-09-20 12:34:43 UTC
Apparently the issue is still there. Tested with Erlang from Fedora 29.

So let's reopen issue 1456567.

*** This bug has been marked as a duplicate of bug 1456567 ***


Note You need to log in before you can comment on or make changes to this bug.