Bug 1295669 - RFE: Optimize metadata download to save bandwidth
RFE: Optimize metadata download to save bandwidth
Status: CLOSED DUPLICATE of bug 850896
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 02:52 EST by Raghavendra Talur
Modified: 2016-01-11 07:43 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 07:43:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Talur 2016-01-05 02:52:07 EST
Description of problem:
Every time dnf has to resync metadata it downloads huge amount of metadata and takes a long time.

example:
Fedora 23 - x86_64 - Updates 114 kB/s |  16 MB     02:21

This is after having updated my system the previous day.
The size of updates turned out to be lesser than 16 MB.

It would be great if some optimization is done to reduce metadata size using rsync or something similar.
Comment 1 Honza Silhan 2016-01-11 07:43:21 EST
I see the two issues. It should not redownload the metadata with the same checksums (bug 1226724) but in general we would like to have better metadata format (send just deltas).

*** This bug has been marked as a duplicate of bug 850896 ***

Note You need to log in before you can comment on or make changes to this bug.