Bug 1295676 - Implement the sssd compat mode in nsswitch.conf man page. [NEEDINFO]
Implement the sssd compat mode in nsswitch.conf man page.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.8
All Linux
low Severity low
: rc
: ---
Assigned To: Nikola Forró
Iveta Wiedermann
: ManPageChange, Patch
Depends On:
Blocks: 1269194 1392401
  Show dependency treegraph
 
Reported: 2016-01-05 03:30 EST by Maurizio Schena
Modified: 2017-03-21 07:49 EDT (History)
9 users (show)

See Also:
Fixed In Version: man-pages-overrides-6.9.0-1.el6
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-21 07:49:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
nforro: needinfo? (mschena)


Attachments (Terms of Use)
Patch for RHEL6 version of the man page (816 bytes, patch)
2016-11-01 09:34 EDT, Nikola Forró
no flags Details | Diff

  None (edit)
Description Maurizio Schena 2016-01-05 03:30:58 EST
Description of problem:

Would be helpful to implement a description of NSS compatibility mode in the nsswitch.conf man page as described in the following Red HAt documentation:

https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/Configuration_Options-NSS_Configuration_Options.html

In the paragraph " ⁠NSS Compatibility Mode".
Comment 2 Florian Weimer 2016-01-05 03:44:56 EST
nsswitch.conf is part of the man-pages package, therefore reassigning.

$ rpm -qf /usr/share/man/man5/nsswitch.conf.5.gz 
man-pages-3.22-20.el6.noarch
Comment 3 Nikola Forró 2016-01-19 09:02:29 EST
Hello,

the following patch has been sent and accepted upstream:
http://www.spinics.net/lists/linux-man/msg09895.html

It should be obvious now from the manpage that any NSS service including sss can be used as the source for passwd_compat pseudo-database.

Maurizio, is this sufficient?
Comment 4 Nikola Forró 2016-11-01 09:34 EDT
Created attachment 1216116 [details]
Patch for RHEL6 version of the man page
Comment 12 errata-xmlrpc 2017-03-21 07:49:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0783.html

Note You need to log in before you can comment on or make changes to this bug.