Bug 1295677 - Couldn't run oadm/oc commands with space character in options on a containerized environment
Couldn't run oadm/oc commands with space character in options on a containeri...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.1.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Scott Dodson
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 03:32 EST by Gaoyun Pei
Modified: 2016-07-03 20:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-27 14:43:55 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gaoyun Pei 2016-01-05 03:32:00 EST
Description of problem:
After setting up a containerized environment, run oadm/oc command on the master host, if there's spaces in the option, the command couldn't get executed properly. 

Version-Release number of selected component (if applicable):
https://github.com/openshift/openshift-ansible -b master

How reproducible:
Always

Steps to Reproduce:
1.Setting up a containerized environment using latest openshift-ansible
 
2.Create a new project on the master host
[root@openshift-145 ~]# oadm new-project test --display-name="Web Team Development" --description="Development project for the web team."

error: you must specify one argument: project name
See 'oadm new-project -h' for help and examples.


Actual results:
Create project failed.

Expected results:
Should run successfully

Additional info:
This issue is also blocking the normal containerized installation, ansible would create "management-infra" project with "--description=Management Infrastructure"  during the master setup, but failed on this step.
Comment 1 Scott Dodson 2016-01-06 10:17:00 EST
Proposed fix in this PR

https://github.com/openshift/openshift-ansible/pull/1115

You may try it by :

git checkout -b bz1295677
git pull https://github.com/sdodson/openshift-ansible bz1295677
Comment 2 Gaoyun Pei 2016-01-06 23:10:47 EST
Install a containerized env with https://github.com/sdodson/openshift-ansible -b bz1295677

[root@openshift-v3 ~]# oadm new-project test --display-name="test prject"
Created project test
[root@openshift-v3 ~]# oc get project
NAME               DISPLAY NAME           STATUS
default                                   Active
management-infra                          Active
openshift                                 Active
openshift-infra                           Active
test               test prject            Active

The issue is fixed, thanks!
Comment 4 errata-xmlrpc 2016-01-27 14:43:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0075

Note You need to log in before you can comment on or make changes to this bug.