Bug 1295696 - glusterd: quota hook script fails on dev environment
glusterd: quota hook script fails on dev environment
Status: CLOSED WONTFIX
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vijaikumar Mallikarjuna
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 04:56 EST by Vijaikumar Mallikarjuna
Modified: 2016-05-11 18:49 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-06 23:26:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vijaikumar Mallikarjuna 2016-01-05 04:56:42 EST
Quota hook scripts fails to run glusterfs with
error 'command not found'

This is because, gluster binaries are installed
under /usr/local/sbin. When glusterd is started
as a init.d service, PATH environment is reset
and doesn't include '/usr/local/sbin' in it.
Comment 1 Vijay Bellur 2016-01-05 05:02:24 EST
REVIEW: http://review.gluster.org/13171 (glusterd: set PATH with gluster sbindir in glusterd startup script) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Mike McCune 2016-03-28 19:44:20 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 3 Vijaikumar Mallikarjuna 2016-04-06 23:26:45 EDT
Patch 'http://review.gluster.org/13171' is abandoned, marking as won't fix

Note You need to log in before you can comment on or make changes to this bug.