Bug 1295704 - RFE: Provide a mechanism to disable some tests in regression
RFE: Provide a mechanism to disable some tests in regression
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tests (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra Talur
: Reopened
Depends On:
Blocks: 1316533
  Show dependency treegraph
 
Reported: 2016-01-05 05:09 EST by Raghavendra Talur
Modified: 2016-06-16 09:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1316533 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:53:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Talur 2016-01-05 05:09:16 EST
Description of problem:

Sometimes it is useful to have a test in test repo but not execute in regression runs.

Reasons could be:
1. Test is not deterministic enough or corrupts environment etc.
2. We don't have a fix yet but the test is already there.


tests/bad_tests serves as the directory where we can send type 1 tests mentioned above. You can use "git mv" to move the .t file from its current place to tests/bad_tests. Make sure you file a bug on the test file and use that for mv patch.

tests/known_bugs serves as the directory where we can send type 2 tests mentioned above. You can use "git mv" to move the .t file from its current place to tests/known_bugs or add a new .t file directly under tests/known_bugs. Make sure you file a bug for the bug you have discovered and use that for mv/add patch.
Comment 1 Vijay Bellur 2016-01-05 05:40:12 EST
REVIEW: http://review.gluster.org/13173 (tests: Introduce mechanism to disable tests) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 2 Vijay Bellur 2016-01-12 05:00:27 EST
REVIEW: http://review.gluster.org/13173 (tests: Introduce mechanism to disable tests) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 3 Vijay Bellur 2016-01-12 23:31:11 EST
REVIEW: http://review.gluster.org/13173 (tests: Introduce mechanism to disable tests) posted (#3) for review on master by Atin Mukherjee (amukherj@redhat.com)
Comment 4 Vijay Bellur 2016-02-08 02:14:13 EST
REVIEW: http://review.gluster.org/13393 (tests: Add mechanism for disabled tests) posted (#1) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 5 Vijay Bellur 2016-03-02 15:19:22 EST
REVIEW: http://review.gluster.org/13393 (tests: Add mechanism for disabled tests) posted (#2) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 6 Vijay Bellur 2016-03-02 16:15:42 EST
REVIEW: http://review.gluster.org/13393 (tests: Add mechanism for disabled tests) posted (#3) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 7 Vijay Bellur 2016-03-08 13:55:52 EST
REVIEW: http://review.gluster.org/13393 (tests: Add mechanism for disabled tests) posted (#4) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 8 Vijay Bellur 2016-03-08 13:59:05 EST
REVIEW: http://review.gluster.org/13393 (tests: Add mechanism for disabled tests) posted (#5) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 9 Vijay Bellur 2016-03-08 14:00:21 EST
REVIEW: http://review.gluster.org/13393 (tests: Add mechanism for disabled tests) posted (#6) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 10 Vijay Bellur 2016-03-09 01:38:22 EST
REVIEW: http://review.gluster.org/13393 (tests: Add mechanism for disabled tests) posted (#7) for review on master by Raghavendra Talur (rtalur@redhat.com)
Comment 11 Vijay Bellur 2016-03-10 02:19:46 EST
COMMIT: http://review.gluster.org/13393 committed in master by Raghavendra Talur (rtalur@redhat.com) 
------
commit f6e5bc68d294cc67f1e7f4db043d2531d4cfec80
Author: Raghavendra Talur <rtalur@redhat.com>
Date:   Mon Feb 8 12:13:54 2016 +0530

    tests: Add mechanism for disabled tests
    
    Requirements:
    Should be able to skip tests from run-tests.sh run.
    Should be granular enough to disable on subset of OSes.
    
    Solution:
    Tests can have special comment lines with some comma separated values
    within them.
    
    Key names used to determine test status are
    G_TESTDEF_TEST_STATUS_CENTOS6
    G_TESTDEF_TEST_STATUS_NETBSD7
    Some examples:
    G_TESTDEF_TEST_STATUS_CENTOS6=BAD_TEST,BUG=123456
    G_TESTDEF_TEST_STATUS_NETBSD7=KNOWN_ISSUE,BUG=4444444
    G_TESTDEF_TEST_STATUS_CENTOS6=BAD_TEST,BUG=123456;555555
    You can change status of test to enabled or delete the line only if all the
    bugs are closed or modified or if the patch fixes it.
    
    Change-Id: Idee21fecaa5837fd4bd06e613f5c07a024f7b0c2
    BUG: 1295704
    Signed-off-by: Raghavendra Talur <rtalur@redhat.com>
    Reviewed-on: http://review.gluster.org/13393
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Rajesh Joseph <rjoseph@redhat.com>
    Reviewed-by: Kaushal M <kaushal@redhat.com>
Comment 12 Niels de Vos 2016-06-16 09:53:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.