Bug 1295706 - puppet agent -t -v fails with "Error: Could not retrieve catalog from remote server: Error 400 on SERVER"
Summary: puppet agent -t -v fails with "Error: Could not retrieve catalog from remote ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: SCAP Plugin
Version: 6.1.5
Hardware: All
OS: Linux
medium
medium vote
Target Milestone: Unspecified
Assignee: Katello Bug Bin
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-01-05 10:13 UTC by Kamudini Gazdikova
Modified: 2019-09-12 09:41 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 09:22:20 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1501 normal SHIPPED_LIVE Red Hat Satellite 6.2 Capsule and Server 2016-07-27 12:28:58 UTC

Comment 1 Marek Hulan 2016-01-05 10:22:02 UTC
This was caused by wrong default value of policies puppet parameter. During previous failed saves it got wrongly escaped, a lot of \\\\" were part of the value. The solution was to change default value but the problem is that if we changed only default value, the record was not saved. A workaround was to change type as well (array to string), then the default value change was picked. After the save we reverted type back.

Comment 6 Kedar Bidarkar 2016-04-04 20:24:01 UTC
Can you please provide some verification steps for this bug.

Comment 7 Kedar Bidarkar 2016-04-04 20:27:48 UTC
sorry I asked needinfo for wrong bug.

Comment 8 Kedar Bidarkar 2016-04-04 20:37:22 UTC
followed the steps mentioned in the initial bug description, this issue is no longer seen with sat62-snap6

VERIFIED with sat62-snap6

Comment 10 errata-xmlrpc 2016-07-27 09:22:20 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501


Note You need to log in before you can comment on or make changes to this bug.