Bug 1295736 - "Operation not supported" error logs seen continuosly in brick logs
"Operation not supported" error logs seen continuosly in brick logs
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: tier (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity urgent
: ---
: RHGS 3.1.2
Assigned To: Mohammed Rafi KC
nchilaka
: Regression, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 06:21 EST by nchilaka
Modified: 2016-09-17 11:40 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.5-15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-01 01:06:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nchilaka 2016-01-05 06:21:03 EST
I am seeing the following error continously on brick logs. these logs are also eating my disk space. It seems to be a regression. 

[2016-01-04 13:40:02.812930] I [glusterfsd-mgmt.c:1596:mgmt_getspec_cbk] 0-glusterfs: No change in volfile, continuing
[2016-01-04 13:40:02.885935] E [MSGID: 113001] [posix-helpers.c:1177:posix_handle_pair] 0-stress-posix: /rhs/brick5/stress_hot/kern.legacy/dir.369/linux-4.3.3/tools/lib/api/fd/array.h: key:tier-linkfile-gfidflags: 1 length:16 [Operation not supported]
[2016-01-04 13:40:02.885978] E [MSGID: 113001] [posix.c:2621:posix_create] 0-stress-posix: setting xattrs on /rhs/brick5/stress_hot/kern.legacy/dir.369/linux-4.3.3/tools/lib/api/fd/array.h failed  [Operation not supported]
[2016-01-04 13:40:03.017436] E [marker-quota.c:483:mq_get_set_dirty] 0-stress-marker: failed to get inode ctx for /kern.legacy/dir.362/linux-4.3.3/drivers/staging/rtl8192e
[2016-01-04 13:40:03.030203] E [MSGID: 113001] [posix-helpers.c:1177:posix_handle_pair] 0-stress-posix: /rhs/brick5/stress_hot/kern.legacy/dir.369/linux-4.3.3/tools/lib/api/fs/Build: key:tier-linkfile-gfidflags: 1 length:16 [Operation not supported]
[2016-01-04 13:40:03.030239] E [MSGID: 113001] [posix.c:2621:posix_create] 0-stress-posix: setting xattrs on /rhs/brick5/stress_hot/kern.legacy/dir.369/linux-4.3.3/tools/lib/api/fs/Build failed  [Operation not supported]
[2016-01-04 13:40:03.067864] E [MSGID: 113001] [posix-helpers.c:1177:posix_handle_pair] 0-stress-posix: /rhs/brick5/stress_hot/kern.legacy/dir.369/linux-4.3.3/tools/lib/api/fs/debugfs.c: key:tier-linkfile-gfidflags: 1 length:16 [Operation not supported]
[2016-01-04 13:40:03.067908] E [MSGID: 113001] [posix.c:2621:posix_create] 0-stress-posix: setting xattrs on /rhs/brick5/stress_hot/kern.legacy/dir.369/linux-4.3.3/tools/lib/api/fs/debugfs.c failed  [Operation not supported]
[2016-01-04 13:40:03.119516] E [MSGID: 113001] [posix-helpers.c:1177:posix_handle_pair] 0-stress-posix: /rhs/brick5/stress_hot/kern.legacy/dir.369/linux-4.3.3/tools/lib/api/fs/debugfs.h: key:tier-linkfile-gfidflags: 1 length:16 [Operation not supported]
[2016-01-04 13:40:03.119554] E [MSGID: 113001] [posix.c:2621:posix_create] 0-stress-posix: setting xattrs on /rhs/brick5/stress_hot/kern.legacy/dir.369/linux-4.3.3/tools/lib/api/fs/debugfs.h failed  [Operation not supported]
[2016-01-04 13:40:03.135369] E [MSGID: 113091] [posix.c:3836:posix_get_ancestry_non_directory] 0-stres




Version:
3.7.5-13
Comment 2 Mohammed Rafi KC 2016-01-06 01:48:49 EST
upstream patch : http://review.gluster.org/#/c/13130/
Comment 4 krishnaram Karthick 2016-02-02 04:50:41 EST
Verified in build glusterfs-3.7.5-17.el7rhgs.x86_64. These error messages are no more seen in brick logs.
Comment 6 errata-xmlrpc 2016-03-01 01:06:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0193.html

Note You need to log in before you can comment on or make changes to this bug.