Bug 1295763 - Unable to modify quota hard limit on tier volume after disk limit got exceeded
Unable to modify quota hard limit on tier volume after disk limit got exceeded
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity high
: ---
: ---
Assigned To: Manikandan
: Regression, Triaged, ZStream
Depends On: 1294816
Blocks: 1296024
  Show dependency treegraph
 
Reported: 2016-01-05 07:19 EST by Vijaikumar Mallikarjuna
Modified: 2016-06-16 09:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1294816
: 1296024 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:53:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-05 07:21:33 EST
REVIEW: http://review.gluster.org/13174 (glusterd: register rpc notification for unix sockets) posted (#1) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 2 Vijay Bellur 2016-01-18 09:18:34 EST
REVIEW: http://review.gluster.org/13174 (glusterd: register rpc notification for unix sockets) posted (#2) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 3 Vijay Bellur 2016-01-19 03:20:35 EST
REVIEW: http://review.gluster.org/13174 (glusterd: register rpc notification for unix sockets) posted (#3) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 4 Vijay Bellur 2016-01-27 04:26:38 EST
REVIEW: http://review.gluster.org/13174 (glusterd: register rpc notification for unix sockets) posted (#4) for review on master by Kaushal M (kaushal@redhat.com)
Comment 5 Vijay Bellur 2016-01-27 07:12:57 EST
REVIEW: http://review.gluster.org/13174 (glusterd: register rpc notification for unix sockets) posted (#5) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 6 Vijay Bellur 2016-01-28 01:30:24 EST
REVIEW: http://review.gluster.org/13174 (glusterd: register rpc notification for unix sockets) posted (#6) for review on master by Vijaikumar Mallikarjuna (vmallika@redhat.com)
Comment 7 Vijay Bellur 2016-01-29 01:19:56 EST
COMMIT: http://review.gluster.org/13174 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 2fa5f7267801c3bff25f813ff6eb44305e56b0b5
Author: vmallika <vmallika@redhat.com>
Date:   Tue Jan 5 17:50:09 2016 +0530

    glusterd: register rpc notification for unix sockets
    
    Previously only CLI was using unix socket to connect to glusterd,
    and there was no need to register rpc callback notifications.
    Now auxiliary mount process is started with unix socket option.
    
    So we need to register register rpc notifications for unix sockets as
    well.
    
    Change-Id: I985839fc91c5c2674d85a7ec94ae24f47898c22d
    BUG: 1295763
    Signed-off-by: vmallika <vmallika@redhat.com>
    Reviewed-on: http://review.gluster.org/13174
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 10 Niels de Vos 2016-06-16 09:53:22 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.