Bug 129577 - Mount -t smbfs leads to system crash
Mount -t smbfs leads to system crash
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-08-10 11:39 EDT by Eric Remy
Modified: 2015-01-04 17:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 01:53:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Eric Remy 2004-08-10 11:39:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040614 Firefox/0.8

Description of problem:
When attempting to mount a SMB share using Fedora Core 2 and Samba
2.0.3-5 the mount will appear to succeed- no error message is
returned, the mount log shows success.

Upon cd-ing to the mount point, the system will crash within the first
few file actions such as ls, cp or mv from the machine to the share,
etc.  The system crash is total: I have to use the hardware reset
button to restart the machine.   I've been unable to find any log that
shows any signs of error- the logs show a successful mount, and then
the boot messages.

It will occasionally let several commands though: I've managed to get
as far as browsing through 2 directories and copying a file once.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Mount SMB share
2. Go to share point, perform file actions

Actual Results:  System crash

Expected Results:  Act like a typical mount

Additional info:

This error occurs on two seperate machines, a Dell Optiplex and a
Penguin Computing dual-Xeon server which share no hardware in common.
 The server was able to connect to this mount point using RH9 before
upgrading to FC2 yesterday.
Comment 1 Jay Hampton 2004-08-13 14:24:52 EDT
Having the same problem with fc2.  mount -t smbfs hard locks the
system requiring power cycle.  Only happens when mounting a "snap
appliance" server.  No problems when mounting a samba share on a
Redhat 7.3 server.  Also- no problems smbmounting the snap server from
Redhat 7.3, 8.0 or 9.0.  Only with FC2

I can do a few ls or cd commands before the crash. Nothing unusual in
the logs.  This is all from bash with no X running.

Tried both Samba 3.0.0-15 and 3.0.3-5.  Even tried different brand
NICs. Maybe a kernel problem?

Work around for now was to switch to NFS.

Comment 2 Jay Fenlason 2004-08-17 14:19:31 EDT
Anything that happens after the mount command finishes is a kernel 
problem rather than a Samba problem.  I'm reassinging this to the 
kernel folks. 
Comment 3 Arjan van de Ven 2004-08-17 14:22:25 EDT
Which kernel version is this?
Is this the released update kernel ?
Comment 4 Eric Remy 2004-08-17 15:46:06 EDT
This is both the stock FC2 kernel as well as the one with all updates

On the Penguin computing server, kernel-smp-2.6.7-1.494.2.2
On the Dell desktop: kernel-smp-2.6.5-1.358

As with Jay Hampton, this is also with a snap server.
Comment 5 Jay Hampton 2004-08-17 20:47:23 EDT
FC2, tried both:

FYI- After much googling, I saw some folks mention MS 'webclient'
service can be an issue when connecting to some windows servers.  The
Snap server does supports html access, and it cannot be completely
turned off.  So, I blocked outgoing port 80 via iptables from my FC2
system, but still no joy.

No problem when using an old RH system running kernel-2.4.18-14.

Comment 6 Dave Jones 2005-01-17 03:33:03 EST
this should have been fixed by now. can you reproduce this in the latest kernels ?
Comment 7 Jay Hampton 2005-01-17 11:26:10 EST
Got this email regrading regarding a similiar bug report over on the kernel
bugzilla.  I have not tried the latest kernel, however, this patch worked for me
against 2.6.9:

"Hey, just a heads-up - there's a patch on the bugzilla now which is
working for me against 2.6.9. Zwane warns that there may be SMP issues,
but I don't have an SMP machine.

Comment 8 Eric Remy 2005-01-17 11:38:43 EST
Hmm.  My staging server is uniprocessor, but the actual live machine is SMP. 
Given that classes started today[1], I can't risk testing this right now.  (It
runs our learning management system)  I'll give it a shot over spring break.

[1] And I'm working half days for the next month since I brought home my second
son from the hospital on Saturday...  Given how tired I am, I'd probably end up
installing 1.4.2 or something.
Comment 9 Jay Hampton 2005-01-27 23:51:33 EST
Tried kernel-2.6.10-1.9_FC2 and I still froze after a few 'ls' and 'cd' commands
on run on the shared drive from my snap server.  Will go back to my patched
2.6.9. . . 
Comment 10 Dave Jones 2005-04-16 01:53:49 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.