Bug 1295770 - hammer listing the sc-params doesn't displays the associated puppet class.
hammer listing the sc-params doesn't displays the associated puppet class.
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: orabin
Katello QA List
http://projects.theforeman.org/issues...
:
Depends On:
Blocks: 1278718
  Show dependency treegraph
 
Reported: 2016-01-05 07:24 EST by Jitendra Yejare
Modified: 2016-07-27 07:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:16:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot Attached. (118.18 KB, image/png)
2016-01-05 07:24 EST, Jitendra Yejare
no flags Details
[Verified] Screenshot Attached (198.58 KB, image/png)
2016-05-19 08:53 EDT, Jitendra Yejare
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12998 None None None 2016-04-22 13:20 EDT
Foreman Issue Tracker 13101 None None None 2016-04-22 13:21 EDT

  None (edit)
Description Jitendra Yejare 2016-01-05 07:24:17 EST
Created attachment 1111816 [details]
Screenshot Attached.

Description of problem:
List the smart class parameters using hammer command :
'hammer -u <user> -p <passwd> sc-param list'
or with any subcommands available to display sc-params which has PUPPET_CLASS column.

Version-Release number of selected component (if applicable):
foreman-1.11.0-0.develop.201512111432git98f6ca5.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. List the smart class parameters in satellite using hammer.
2.
3.

Actual results:
List doesn't shows the associated Puppet Class for each parameter under column 'PUPPET_CLASS'

Expected results:
List should show the associated Puppet Class for each parameter under column 'PUPPET_CLASS'

Additional info:
Comment 3 Bryan Kearney 2016-01-05 08:05:41 EST
Upstream bug component is Provisioning
Comment 4 Bryan Kearney 2016-01-10 08:05:12 EST
Upstream bug component is Hammer
Comment 5 Bryan Kearney 2016-02-10 17:12:59 EST
Upstream bugs are marked as closed. This bug will be included in 6.2
Comment 7 Jitendra Yejare 2016-03-23 02:58:52 EDT
The issue is still reproducible in Sat 6.2 snap 4.

Its not showing associated puppet class name.

Moving the state to 'Failed QA'.
Comment 12 Jitendra Yejare 2016-05-19 08:53 EDT
Created attachment 1159470 [details]
[Verified] Screenshot Attached
Comment 13 Jitendra Yejare 2016-05-19 08:53:57 EDT
Verified !

@Sat 6.2 Snap 11

Listing smart class parameters shows the puppet class for each parameter as UI.

Verified Screenshot Attached.
Comment 14 Bryan Kearney 2016-07-27 07:16:49 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.