Bug 1295785 - python-nova contains *.po files
python-nova contains *.po files
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
unspecified Severity unspecified
: ga
: 8.0 (Liberty)
Assigned To: Sven Anderson
Prasanth Anbalagan
:
Depends On: 892602
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 08:07 EST by Attila Fazekas
Modified: 2016-04-26 14:56 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-nova-12.0.1-3.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:20:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Remove .po/.pot files from package (1.43 KB, patch)
2016-02-08 07:54 EST, Sven Anderson
no flags Details | Diff
Remove .po/.pot files from package (1.48 KB, patch)
2016-02-12 11:44 EST, Sven Anderson
svanders: review?
Details | Diff

  None (edit)
Description Attila Fazekas 2016-01-05 08:07:43 EST
Description of problem:
*.po files are the source of the *.mo files.

Version-Release number of selected component (if applicable):
python-nova-12.0.0-3.el7ost.noarch


Actual results:
*.po files not in use, just occupies space.


Expected results:
Package *.mo files, instead of *.po.


Additional info:
The issue not only python-nova related,
this bug might be used as template for other project.

Other projects might use lazy mode for locale lookup, which
causes extra stat calls.
Comment 2 Sven Anderson 2016-01-25 08:55:45 EST
The spec files don't call "setup.py compile_catalog", so the .mo files have never been created.

I'm just working upstream to fix https://bugs.launchpad.net/openstack-i18n/+bug/1536226 so that all .mo files are generated.

Then I will add the missing "setup.py compile_catalog" to the spec file in order to create the mo. files and let it remove the .po files as well.
Comment 3 Sven Anderson 2016-02-08 07:54 EST
Created attachment 1122153 [details]
Remove .po/.pot files from package
Comment 4 Sven Anderson 2016-02-12 11:44 EST
Created attachment 1123578 [details]
Remove .po/.pot files from package
Comment 7 Prasanth Anbalagan 2016-02-23 08:31:21 EST
Verified as follows - no *.po files found

Version
========

[root@lynx13 ~]# yum list installed | grep openstack-nova
openstack-nova-api.noarch            1:12.0.1-6.el7ost       @RH7-RHOS-8.0      
openstack-nova-cert.noarch           1:12.0.1-6.el7ost       @RH7-RHOS-8.0      
openstack-nova-common.noarch         1:12.0.1-6.el7ost       @RH7-RHOS-8.0      
openstack-nova-compute.noarch        1:12.0.1-6.el7ost       @RH7-RHOS-8.0      
openstack-nova-conductor.noarch      1:12.0.1-6.el7ost       @RH7-RHOS-8.0      
openstack-nova-console.noarch        1:12.0.1-6.el7ost       @RH7-RHOS-8.0      
openstack-nova-novncproxy.noarch     1:12.0.1-6.el7ost       @RH7-RHOS-8.0      
openstack-nova-scheduler.noarch      1:12.0.1-6.el7ost       @RH7-RHOS-8.0 

Logs
======
     
[root@lynx13 ~]# find /usr/lib/python2.7/site-packages/nova -name *.po
[root@lynx13 ~]# 
[root@lynx13 ~]# find /usr/lib/python2.7/site-packages -name *.po | grep nova
[root@lynx13 ~]#
Comment 8 errata-xmlrpc 2016-04-07 17:20:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.