Bug 129579 - Kickstart install chooses incorrect ISO images via NFS
Kickstart install chooses incorrect ISO images via NFS
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: anaconda (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-10 11:52 EDT by Tim Yocum
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-10 15:53:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart configuration (548 bytes, text/plain)
2004-08-10 11:53 EDT, Tim Yocum
no flags Details

  None (edit)
Description Tim Yocum 2004-08-10 11:52:03 EDT
Description of problem:
Summary: 

Network (NFS) install fails when ISOs not belonging to RHEL are in
same directory as RHEL ISOs.

Details:

I have a centralized file server, isis. It is exporting "/netinstall"
via NFS, for network installs of various software -- FreeBSD, Fedora
Core 2, RHEL, etc. Both FreeBSD and Fedora install just fine from this
shared repository, whereas RHEL seems to be getting jealous and
refuses to install. When I use a tried-and-true kickstart file for
RHEL, it complains about missing files and corrupt CDs right as it
would start to snag files. However, if I remove the other OS
distribution ISOs from that directory, leaving just RHEL ISOs and the
kickstart config, it works flawlessly.

I have attached my kickstart configuration file for reference.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Set up an NFS server as you normally would for a kickstart/NFS install.
2. Populate the exported filesystem with RHEL ISOs and kickstart
config file.
3. Add other ISO files to same exported filesystem that do not belong
to the RHEL distribution.
4. Attempt kickstart installation using NFS (linux ks=nfs:server:/export)

Actual Results:  After kickstart begins, Anaconda spews thousands of
lines of warnings about files missing from the distribution.

Expected Results:  The install should have succeeded, as the files are
in the right place, accessable, and have been verified good.

Additional info:
Comment 1 Tim Yocum 2004-08-10 11:53:53 EDT
Created attachment 102573 [details]
Kickstart configuration
Comment 2 Jeremy Katz 2004-08-10 15:53:16 EDT
This is as it should be, there's no way to really match up between the
boot image and the ISOs.

One set of install ISOs per directory is the rule.
Comment 3 Tim Yocum 2004-08-10 15:56:48 EDT
Hopefully the correct functionality as it works in Fedora will be
backported, since it is functional and acceptable behavior. Clearly
Fedora's version of anaconda is more intelligent. Thanks.

Note You need to log in before you can comment on or make changes to this bug.