Bug 1295799 - Mobile Broadband modem device not in any firewalld zone.
Mobile Broadband modem device not in any firewalld zone.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 08:45 EST by colin.caine@manchester.ac.uk
Modified: 2016-07-15 11:56 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-15 11:56:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description colin.caine@manchester.ac.uk 2016-01-05 08:45:47 EST
Description of problem:


Version-Release number of selected component (if applicable):
NM: 1.0.6 8-fc23
ModemManager:
Version     : 1.4.10
Release     : 2.fc23

firewalld-0.3.14.2-4.fc23.noarch

How reproducible:
Always

Steps to Reproduce:
1. Attempt to connect to mobile broadband from gnome (probably also from any other nm interface).
2. Check journalctl

Actual results:
Jan 05 13:28:12 scamper.lan /firewalld[781]: 2016-01-05 13:28:12 ERROR: UNKNOWN_INTERFACE: 'cdc-wdm0' is not in any zone

Expected results:
mobile broadband device should be assigned a zone automatically on installation of ModemManager or added by networkmanager or modemmanager when it tried to use it.
Additional info:
I've no idea what zone it should be in. Wireless device seems to go in FedoraWorkstation zone and I think it's added dynamically.
Comment 1 Thomas Woerner 2016-01-05 09:17:18 EST
The message is there, because a tool (maybe NetworkManager?) is calling the removeZone D-Bus method of firewalld with the interface name as argument. If the interface has not been bound to a zone before, the error is reported.

Please check if the interface is not bound to a zone with

  firewall-cmd --get-zone-of-interface=cdc-wdm0

when it was created and activated.
Comment 2 colin.caine@manchester.ac.uk 2016-02-01 09:54:49 EST
interface is not bound before connection is made or after an attempt at
a connection is made.

Cannot get modem to connect properly, so cannot test to see if it is
correctly assigned a zone after connection.

Happy for bug to be closed.

(Previously emailed this, but didn't seem to work.)
Comment 3 Thomas Woerner 2016-07-15 11:56:03 EDT
Closing as of comment 2.

Note You need to log in before you can comment on or make changes to this bug.