Bug 1295816 - Traceback displayed when exitting fusor-installer with ctrl+c
Traceback displayed when exitting fusor-installer with ctrl+c
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: fusor-installer (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity low
: ---
: 1.1
Assigned To: jkim
Tasos Papaioannou
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 09:31 EST by Antonin Pagac
Modified: 2017-02-27 20:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-27 20:37:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Antonin Pagac 2016-01-05 09:31:39 EST
Description of problem:
Exitting fusor-installer at the first (NIC selection) step using ctrl+c causes an traceback to be displayed.
This does NOT happen on the first-ever run of the fusor-installer (for example on first log-in to the freshly installed machine). In that case, after hitting ctrl+c the console disappears.

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20151223.t.0-RHCI-x86_64-dvd1.iso

How reproducible:
Always

Steps to Reproduce:
1. Open a console on installed RHCI system
2. Run fusor-installer
3. Hit ctrl+c after it asks you to choose NIC

Actual results:
fusor-installer exits with a traceback in console

Expected results:
fusor-installer should exit quietly, or with a sensible error/warning

Additional info:
Output from fusor-installer:

Select which NIC to use for provisioning:
1. eth0
2. eth1
3. eth2
4. eth3
?  ^C/usr/share/gems/gems/highline-1.6.21/lib/highline.rb:863:in `eof?': Interrupt
	from /usr/share/gems/gems/highline-1.6.21/lib/highline.rb:863:in `get_line'
	from /usr/share/gems/gems/highline-1.6.21/lib/highline.rb:885:in `get_response'
	from /usr/share/gems/gems/highline-1.6.21/lib/highline.rb:260:in `ask'
	from /usr/share/gems/gems/highline-1.6.21/lib/highline.rb:361:in `choose'
	from /usr/share/katello-installer/hooks/lib/provisioning_wizard.rb:284:in `get_interface'
	from /usr/share/katello-installer/hooks/lib/provisioning_wizard.rb:51:in `start'
	from /usr/share/katello-installer/hooks/pre_validations/10-gather_and_set_fusor_values.rb:5:in `block (4 levels) in load'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hooking.rb:32:in `instance_eval'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hooking.rb:32:in `block (4 levels) in load'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hook_context.rb:13:in `instance_exec'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hook_context.rb:13:in `execute'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hooking.rb:49:in `block in execute'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hooking.rb:47:in `each'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/hooking.rb:47:in `execute'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:92:in `execute'
	from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
	from /usr/share/gems/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
	from /usr/share/gems/gems/kafo-0.6.5.9/lib/kafo/kafo_configure.rb:116:in `run'
	from /usr/sbin/fusor-installer:63:in `<main>'
Comment 2 Tasos Papaioannou 2016-10-05 16:16:46 EDT
Verified on QCI-1.1-RHEL-7-20161004.t.0.
Comment 5 errata-xmlrpc 2017-02-27 20:37:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:0335

Note You need to log in before you can comment on or make changes to this bug.