This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 129582 - "save as" dialog bug
"save as" dialog bug
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gedit (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks: FC3Target
  Show dependency treegraph
 
Reported: 2004-08-10 12:30 EDT by Tim Waugh
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-16 22:23:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2004-08-10 12:30:46 EDT
Description of problem:
This isn't a gedit bug, but I've no idea which component is right. 
The symptom can be seen in gedit though.  The "save as" dialog box
doesn't behave correctly when given a full pathname.

Version-Release number of selected component (if applicable):
gedit-2.7.90-1

How reproducible:
100%

Steps to Reproduce:
1. Start gedit
2. Ctrl-Shift-S to "Save As" 
3. Type a full pathname with a leading '/', such as '/tmp/foo'
4. Click Save
  
Actual results:
Nothing happens.

Expected results:
File should be saved and dialog should disappear.
Comment 1 Bryan W Clark 2004-08-26 01:47:44 EDT
Tim, is this only when the file /tmp/foo already exists?

I have the feeling this bug has something to do with one of these:
http://bugzilla.gnome.org/show_bug.cgi?id=150852
http://bugzilla.gnome.org/show_bug.cgi?id=146185
Comment 2 Tim Waugh 2004-08-26 05:02:59 EDT
No, it happens with any full pathname with a leading '/'.  There is no
error dialog, it's just that nothing happens (and especially: not the
save).

In fact the behaviour I see with current rawhide is that the 'Save in
folder' drop-down changes from 'Home' to 'Desktop' -- but the file is
not saved, even though I gave a full path and clicked the save button.
Comment 3 Dan Williams 2004-09-16 22:23:14 EDT
Cannot reproduce with 2.7.92-1, seems to be fixed (also is probably a
GTK bug, not gedit)

Note You need to log in before you can comment on or make changes to this bug.