Bug 1295838 - command not understood by program
command not understood by program
Status: CLOSED NOTABUG
Product: GlusterFS
Classification: Community
Component: access-control (Show other bugs)
3.7.6
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: bugs@gluster.org
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 10:25 EST by rdegraaf
Modified: 2016-01-11 04:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-11 03:52:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rdegraaf 2016-01-05 10:25:53 EST
Hello,

Here is the description of my volume :

[root@server glusterfs]# gluster volume info

Volume Name: gluster_volume_0
Type: Replicate
Volume ID: badb87f3-5cdc-40c0-8bec-daa0ed95ea61
Status: Started
Number of Bricks: 1 x 3 = 3
Transport-type: tcp
Bricks:
Brick1: s-teamde-1.de.lan:/DE/gluster_volume
Brick2: s-teamde-2.de.lan:/DE/gluster_volume
Brick3: s-teamde-3.de.lan:/DE/gluster_volume
Options Reconfigured:
auth.allow: 127.0.0.1,192.168.128.*
performance.readdir-ahead: on
performance.cache-size: 256MB
performance.cache-refresh-timeout: 10
[root@server glusterfs]# gluster version
unrecognized word: version (position 0)
[root@server glusterfs]# glusterfs version
USAGE: glusterfs [options] [mountpoint]
[root@server glusterfs]# glusterfs --version
glusterfs 3.7.6 built on Nov  9 2015 15:19:41
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2013 Red Hat, Inc. <http://www.redhat.com/>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
It is licensed to you under your choice of the GNU Lesser
General Public License, version 3 or any later version (LGPLv3
or later), or the GNU General Public License, version 2 (GPLv2),
in all cases as published by the Free Software Foundation.


Description of problem: I tried to pass this command : 

[root@server glusterfs]# gluster volume set gluster_volume_0 auth.reject *

This was the answer the program provided (which doesn't make any sense here) : 

volume set: failed: option : glusterfs-georep-logrotate does not exist
Did you mean client-log-format?


I tried this many times and each time the system answers the same.
Comment 1 Niels de Vos 2016-01-09 07:27:36 EST
  # gluster volume set gluster_volume_0 auth.reject *

If you execute this command, the shell will try to expend the * character to all files in the current directory. You can verify this by putting "echo" in front of the command, like this:

  # echo gluster volume set gluster_volume_0 auth.reject *

In order to pass the * character to the gluster command, you will need to prevent the shell from expanding it. This would do:

  # gluster volume set gluster_volume_0 auth.reject '*'
  volume set: success

Alternatively you can start the Gluster shell and execute the command there:

  # gluster
  gluster> volume set gluster_volume_0 auth.reject *
  volume set: success

Could you let me know if that helps?
Comment 2 rdegraaf 2016-01-11 03:52:42 EST
Ah ok, yes with some explanation it makes a lot more sense.

Thank you, no bug then !

Note You need to log in before you can comment on or make changes to this bug.