Bug 1295849 - Overcloud Update Failure - YUM excludes break package dependencies [NEEDINFO]
Overcloud Update Failure - YUM excludes break package dependencies
Status: CLOSED DUPLICATE of bug 1299022
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity high
: y3
: 7.0 (Kilo)
Assigned To: Hugh Brock
Alexander Chuzhoy
: TestOnly
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 10:37 EST by Jeremy
Modified: 2016-02-10 16:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-09 11:52:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
jmelvin: needinfo? (calfonso)


Attachments (Terms of Use)
yum output (276.33 KB, text/plain)
2016-01-05 10:37 EST, Jeremy
no flags Details
pkg deps (179.28 KB, text/plain)
2016-01-05 10:38 EST, Jeremy
no flags Details

  None (edit)
Description Jeremy 2016-01-05 10:37:56 EST
Created attachment 1111896 [details]
yum output

Description of problem:
When attempting to update the overcloud from OSP 7.1 to 7.2, the update fails on the Compute nodes due to package dependency errors.

The command used to update the overcloud was:

openstack overcloud update stack Lab3 -i --templates ~/templates/my-overcloud/ -e ~/templates/my-overcloud/overcloud-resource-registry-puppet.yaml -e ~/templates/my-overcloud/environments/network-isolation.yaml -e ~/templates/nic-configs/network-environment.yaml -e ~/templates/my-overcloud/environments/storage-environment.yaml -e ~/templates/my-overcloud/firstboot/wipe_disk_resource.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-vip.yaml
starting package update on stack Lab3

templates/my-overcloud/extraconfig/tasks/yum_update.sh uses this command to decide what packages to exclude during the yum update "cat /var/lib/tripleo/installed-packages/* | sort -u"
The output gathered from one of the compute nodes:
ceph
libvirt-daemon-config-nwfilter
libvirt-daemon-kvm
net-snmp
ntp
openstack-ceilometer-common
openstack-ceilometer-compute
openstack-neutron
openstack-neutron-ml2
openstack-neutron-openvswitch
openstack-nova-common
openstack-nova-compute
openvswitch
pm-utils
python-greenlet
python-nova

I have attached a file yum_output showing the dependency errors when running the yum update with and without the excludes.

Also attached is the heat resource output from the compute resource (pkg_dependencies)

Version-Release number of selected component (if applicable):
The environment is using RHEL 7.2.  The Director node has the OSP 7.2 packages and images.

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
resolving the broken packages manually does work, but customer is interested in finding the root cause and/or official solution for making the updates work without manual intervention.
Comment 1 Jeremy 2016-01-05 10:38 EST
Created attachment 1111897 [details]
pkg deps
Comment 6 Jeremy 2016-02-09 11:52:50 EST

*** This bug has been marked as a duplicate of bug 1299022 ***

Note You need to log in before you can comment on or make changes to this bug.