Bug 1295873 - Importing image from Glance as template failes with UI exception
Importing image from Glance as template failes with UI exception
Status: CLOSED WORKSFORME
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
3.6.1.3
Unspecified Unspecified
unspecified Severity medium (vote)
: ovirt-3.6.2
: 3.6.2
Assigned To: Tal Nisan
Pavel Stehlik
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 11:21 EST by Barak Korren
Modified: 2016-03-10 02:24 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-06 09:54:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tnisan: ovirt‑3.6.z?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
screenshot of error message (107.69 KB, image/png)
2016-01-05 11:21 EST, Barak Korren
no flags Details
screenshot of input dialog (118.15 KB, image/png)
2016-01-05 11:25 EST, Barak Korren
no flags Details

  None (edit)
Description Barak Korren 2016-01-05 11:21:07 EST
Created attachment 1111904 [details]
screenshot of error message

Description of problem:
When trying to import an image from Glance as a template in the admin UI, it fails, showing up the UI exception notification at the top of the screen.

Version-Release number of selected component (if applicable):
3.6.1.3-1.el7.centos

Steps to Reproduce:
1. go to storage tab
2. select Glance image provider
3. Select an image from the lower half of the screen
4. click "import"
5. select a data center and storage domain (or leave defaults)
6. check the "Import as Template" checkbox
7. click ok

Actual results:
A UI exception message

Expected results:
A new template based on the image from Glance

Additional info:
Will include screenshots
Comment 1 Barak Korren 2016-01-05 11:25 EST
Created attachment 1111909 [details]
screenshot of input dialog
Comment 2 Barak Korren 2016-01-05 11:30:15 EST
Importing without checking the "Import as Template" checkbox seems to work ok.
Comment 3 Barak Korren 2016-01-06 09:20:21 EST
Looks like this was due to the cluster baing in a bad state is described in: https://bugzilla.redhat.com/show_bug.cgi?id=1296148

There are still import failures, but these are different in nature.
Comment 4 Tal Nisan 2016-01-06 09:54:18 EST
Seems to work in 3.6.2 without the problem described in comment #3 meaning that the problem is the one described in bug 1296148

Note You need to log in before you can comment on or make changes to this bug.