Bug 129588 - Skip host name lookup if no DNS is entered
Skip host name lookup if no DNS is entered
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-10 13:12 EDT by Leonard den Ottolander
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-12 12:10:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonard den Ottolander 2004-08-10 13:12:27 EDT
Anaconda and boot.iso as of 2004-08-09, assuming this is
anaconda-10.0.2-0.20040806112009

On my small home network I do only use an external DNS. Thus when
doing an NFS/FTP/HTTP installation I do not enter a primary nameserver
in the "Configure TCP/IP". Still anaconda is trying to look up the
host name for the machine. Since there is no DNS server providing the
machine with a name this fails. You could thus save the time spent
searching by skipping this step and setting a default host name.

Guess this needs to be fixed in loader2/net.c. Maybe loaderData->noDns
is not set if the DNS string is empty?
Comment 1 Jeremy Katz 2004-08-10 16:01:42 EDT
Sure, committed to CVS
Comment 2 Leonard den Ottolander 2004-08-12 12:10:29 EDT
Works fine for me. Thanks for this quick fix.

Note You need to log in before you can comment on or make changes to this bug.