Bug 1295897 - RHEL 6.7 installation fails with "NameError: global name 'index' is not defined"
RHEL 6.7 installation fails with "NameError: global name 'index' is not defined"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.7
All Linux
unspecified Severity high
: rc
: ---
Assigned To: David Lehman
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 12:47 EST by Mikulas Patocka
Modified: 2016-05-10 16:46 EDT (History)
3 users (show)

See Also:
Fixed In Version: anaconda-13.21.243-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 16:46:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the abrt report from the crash (49.29 KB, application/x-gzip)
2016-01-05 12:47 EST, Mikulas Patocka
no flags Details

  None (edit)
Description Mikulas Patocka 2016-01-05 12:47:32 EST
Created attachment 1111919 [details]
the abrt report from the crash

Description of problem:
RHEL 6.7 installation fails.

Version-Release number of selected component (if applicable):
RHEL-6.7 i686

How reproducible:
Always

Steps to Reproduce:
1. run the i686 RHEL-6.7 installer

Actual results:
it crashes very early, when scanning devices, with this error:
anaconda 13.21.239 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 1614, in addLV
    % (lv_sizes[index], origin.name))
  File "/usr/lib/anaconda/storage/devicetree.py", line 1701, in handleVgLvs
    ret = addLV(*lv) or ret
  File "/usr/lib/anaconda/storage/devicetree.py", line 2138, in _setupLvs
    if self.handleVgLvs(device):
  File "/usr/lib/anaconda/storage/devicetree.py", line 2232, in populate
    if self._setupLvs():
  File "/usr/lib/anaconda/storage/__init__.py", line 467, in reset
    self.devicetree.populate(prog)
  File "/usr/lib/anaconda/storage/__init__.py", line 109, in storageInitialize
    storage.reset(examine_all=examine_all)
  File "/usr/lib/anaconda/dispatch.py", line 210, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1458, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/gui.py", line 1371, in nextClicked
    self.setScreen ()
NameError: global name 'index' is not defined

Expected results:
the installer should not crash

Additional info:
this bug is new to RHEL-6.7. RHEL-6.6 can be installed.
Comment 2 Mikulas Patocka 2016-01-05 13:08:39 EST
This is the list of physical volumes, volume groups and logical volumes that are present on the machine - that is probably causing the crash:
  PV            VG     Fmt  Attr PSize   PFree
  /dev/sdb5     vg1    lvm2 a--    9,32g 5,79g
  /dev/vg1/orig Vg_org lvm2 a--  124,00m    0
  /dev/vg1/snap Vg_cow lvm2 a--  124,00m    0
  VG     #PV #LV #SN Attr   VSize   VFree
  Vg_cow   1   1   0 wz--n- 124,00m    0
  Vg_org   1   1   0 wz--n- 124,00m    0
  vg1      1   8   1 wz--n-   9,32g 5,79g
  LV       VG     Attr       LSize   Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  Lv_cow   Vg_cow -wi------- 124,00m
  Lv_org   Vg_org -wi------- 124,00m
  o        vg1    owi-a-s--- 128,00m
  orig     vg1    -wi-a----- 128,00m
  s1       vg1    swi-a-s--- 128,00m      o      0,00
  snap     vg1    -wi-a----- 128,00m
  stripe   vg1    -wa-a-----  32,00m
  switch-0 vg1    -wi-a-----   1,00g
  switch-1 vg1    -wi-a-----   1,00g
  switch-2 vg1    -wi-a-----   1,00g
Comment 3 Jan Stodola 2016-01-13 05:04:21 EST
Reproduced on a system with an LVM snapshot:

[root@localhost ~]# lvs
  LV       VG       Attr       LSize    Pool Origin   Data%  Meta%  Move Log Cpy%Sync Convert
  LogVol00 VolGroup owi-aos---    1,97g
  LogVol01 VolGroup -wi-ao----  300,00m
  snap     VolGroup swi-a-s--- 1016,00m      LogVol00 0,20
[root@localhost ~]#
Comment 5 Michal Kovarik 2016-02-23 04:43:25 EST
Reproduced on RHEL-6.7. Verified on RHEL-6.8-20160212.2 with anaconda-13.21.246-1.el6.
Comment 7 errata-xmlrpc 2016-05-10 16:46:29 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0798.html

Note You need to log in before you can comment on or make changes to this bug.