Bug 1295898 - vnc_proxy configuration settings not IPv6 compatible
vnc_proxy configuration settings not IPv6 compatible
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
high Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Sofer Athlan-Guyot
Marius Cornea
: TestOnly, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 12:53 EST by Dan Sneddon
Modified: 2016-04-15 09:46 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.11-1.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-15 09:46:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1531960 None None None 2016-01-07 15:59 EST
OpenStack gerrit 264927 None None None 2016-01-07 16:00 EST
OpenStack gerrit 264951 None None None 2016-01-07 16:00 EST

  None (edit)
Description Dan Sneddon 2016-01-05 12:53:20 EST
Description of problem:
The current processing of the nova.conf file results in invalid URLs when IPv6 IPs are used. For IPv6 URLs that contain port numbers, it is required that the IP addresses be inside of square brackets to properly differentiate IP addresses from port numbers. This is required because IPv6 addresses can be shortened if there are repeated zeroes, so it can be impossible to differentiate an IP address from an IP/Port combination.

Version-Release number of selected component (if applicable):
8.0 beta

How reproducible:
100%

Steps to Reproduce:
1. Deploy with IPv6 TripleO Heat templates
2.
3.

Actual results:
/etc/nova.conf novnc URL is in improper format when using IPv6:

novncproxy_base_url=http://fd00:fd00:fd00:2000:f816:3eff:feae:4747:6080/vnc_auto.html


Expected results:
The IP in the URL should appear in brackets:
novncproxy_base_url=http://[fd00:fd00:fd00:2000:f816:3eff:feae:4747]:6080/vnc_auto.html

Additional info:
vncproxy.pp will need to be modified. Today it uses the same hiera value for the values that require a raw IP as the ones that require a bracketed IP.

Proposed fix #1:
Today everything is based on the hieradata value of nova::vncproxy::host. We could modify the TripleO Heat templates to provide a new value in the hieradata, which is the host IP with brackets in the case of IPv6, or without brackets in the case of IPv4. This value might be called nova::vncproxy::host_uri.

This new value should be optional, and should override the value of the host if it exists, but only in the places where the URLs are written.

Proposed fix #2:
The puppet modules themselves can determine if the host IP is an IPv6 address, and write the URLs with brackets in the configuration file if so.
Comment 3 Sofer Athlan-Guyot 2016-01-07 16:01:51 EST
This above patches solves the problem in the puppet module.
Comment 4 Jason Guiditta 2016-02-29 12:56:09 EST
Merged upstream
Comment 9 Marius Cornea 2016-04-10 06:26:23 EDT
openstack-puppet-modules-7.0.17-1.el7ost.noarch

[root@overcloud-controller-0 heat-admin]# grep novncproxy_base_url /etc/nova/nova.conf 
novncproxy_base_url=http://[fd00:fd00:fd00:2000::14]:6080/vnc_auto.html
Comment 11 errata-xmlrpc 2016-04-15 09:46:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0636.html

Note You need to log in before you can comment on or make changes to this bug.