Bug 129590 - Add Phison flash drive to updfstab.conf.default
Summary: Add Phison flash drive to updfstab.conf.default
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-08-10 17:52 UTC by Jason Tibbitts
Modified: 2013-03-06 03:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 18:12:19 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lsusb output (1.83 KB, text/plain)
2004-08-10 17:52 UTC, Jason Tibbitts
no flags Details

Description Jason Tibbitts 2004-08-10 17:52:13 UTC
A user presented a cheap flash drive which was not recognized.  I
updated hwdata to the latest from rawhide (0.123-1) with no luck. 
lsusb output attached; /proc/scsi/scsi shows:

Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor:          Model: USB DISK 2.0     Rev: 1.13
  Type:   Direct-Access                    ANSI SCSI revision: 02

Adding 

device flash {
    partition 1
    match   hd "USB DISK 2.0"
}

to /etc/updfstab.conf makes things work.

Comment 1 Jason Tibbitts 2004-08-10 17:52:48 UTC
Created attachment 102586 [details]
lsusb output

Comment 2 Bill Nottingham 2004-08-10 19:16:25 UTC
Unfortunately, I'm not sure that everything that claims to be "USB
DISK 2.0" will actually be a flash drive. :/

Comment 3 Jason Tibbitts 2004-08-10 19:33:08 UTC
Are there other data which can be used for matching to narrow the
scope?  "USB DISK 2.0" isn't very specific, but

idVendor="Phison Electronics Corp."
idProduct="Flash Disk"
iProduct="USB DISK 2.0"

is pretty narrow.



Comment 4 Bill Nottingham 2004-08-10 19:55:24 UTC
Those vendor/idProduct fields aren't what's used, no.

Comment 5 Bill Nottingham 2004-09-17 21:24:36 UTC
You may want to see how this behaves with current hal and
gnome-volume-manager packages - that's the new way for handling these
devices.

Comment 6 David Zeuthen 2004-09-27 18:12:19 UTC
Closing as RAWHIDE since this should work out-of-the-box in our
development branch. Feel free to reopen the bug if this is not the case.


Note You need to log in before you can comment on or make changes to this bug.