Bug 1295909 - xorg: Glamor driver for virgil
xorg: Glamor driver for virgil
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Dave Airlie
Desktop QE
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 13:38 EST by Ademar Reis
Modified: 2018-04-10 07:50 EDT (History)
6 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.19.3-11.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 07:48:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0736 None None None 2018-04-10 07:50 EDT

  None (edit)
Description Ademar Reis 2016-01-05 13:38:46 EST
We're working to have virtio-gpu (Virgil) fully functional in RHEL 7.3 and for that we need Glamor drivers in Xorg

http://www.freedesktop.org/wiki/Software/Glamor/

I'm not sure what's the minimum version that can be considered stable, this needs to be investigated.
Comment 2 Dave Airlie 2016-02-18 23:47:51 EST
Move to xorg-x11-server since any changes needed to support virgl will need to be done there to the -modesetting driver/glamor combo.
Comment 4 Adam Jackson 2017-09-07 13:16:42 EDT
xserver has had glamor enabled for quite a while, certainly was present already in 7.4. If there are additional fixes needed for virgl in particular please reopen this bug.
Comment 9 errata-xmlrpc 2018-04-10 07:48:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0736

Note You need to log in before you can comment on or make changes to this bug.