Bug 1295919 - rhel-osp-director: deploy oc 7.2 from uc 8.0 without netiso: the deployment finishes with error because it's unable to login with heat-admin.
rhel-osp-director: deploy oc 7.2 from uc 8.0 without netiso: the deployment ...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity high
: ga
: 8.0 (Liberty)
Assigned To: Brad P. Crochet
Alexander Chuzhoy
: Triaged
: 1296676 (view as bug list)
Depends On:
Blocks: 1295992
  Show dependency treegraph
 
Reported: 2016-01-05 14:03 EST by Alexander Chuzhoy
Modified: 2016-04-07 17:44 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-tripleo-heat-templates-0.8.10-2.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:44:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 220057 None None None 2016-02-25 17:25 EST
OpenStack gerrit 284769 None None None 2016-02-25 17:26 EST
Gerrithub.io 264367 None None None 2016-02-25 17:24 EST

  None (edit)
Description Alexander Chuzhoy 2016-01-05 14:03:20 EST
rhel-osp-director: deploy oc 7.2 from uc 8.0  without netiso: the deployment finishes with error because it's unable to login with heat-admin.

Environment:
openstack-tripleo-0.0.7-1.el7ost.noarch
openstack-tripleo-common-0.0.2-4.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch
openstack-tripleo-image-elements-0.9.7-1.el7ost.noarch
instack-undercloud-2.2.0-1.el7ost.noarch
openstack-tripleo-heat-templates-0.8.6-94.el7ost.noarch

Steps to reproduce:
1. Deploy undercloud 8.0.
2. Get/Load images for 7.2 (Note: BZ #1295912)
3. Downgrade the  openstack-tripleo-heat-templates package to 7.2 version.
4. Run a deployment without network isolation:
 openstack overcloud deploy --templates --control-scale 3 --compute-scale 2    --ntp-server x.x.x.x  --timeout 90 

Result:

Deploying templates in the directory /usr/share/openstack-tripleo-heat-templates

^[[24~PKI initialization in init-keystone is deprecated and will be removed.
Warning: Permanently added '192.168.0.6' (ECDSA) to the list of known hosts.
Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
Command '['ssh', '-oStrictHostKeyChecking=no', '-t', '-l', 'heat-admin', u'192.168.0.6', 'sudo', 'keystone-manage', 'pki_setup', '--keystone-user', "$(getent passwd | grep '^keystone' | cut -d: -f1)", '--keystone-group', "$(getent group | grep '^keystone' | cut -d: -f1)"]' returned non-zero exit status 255

Note: it's not possible to login to the overcloud nodes using the heat-admin user.


Expected result:
Successful deployment
Comment 2 Mitsuhiro Tanino 2016-01-07 15:19:43 EST
Hi,

Are there any workaround for this problem?
Comment 3 Mike Burns 2016-01-07 15:34:28 EST
*** Bug 1296676 has been marked as a duplicate of this bug. ***
Comment 4 Mitsuhiro Tanino 2016-01-18 16:45:26 EST
Are there any workaround for this problem?
Comment 5 Mike Burns 2016-01-19 08:09:31 EST
This is ongoing feature work that is not yet complete.  The only workaround at this time is to continue to use OSPd 7 for deployments.
Comment 7 Hugh Brock 2016-02-05 10:36:35 EST
Brad, this may already be fixed, could you update the bug if so?
Comment 8 Hugh Brock 2016-02-05 10:36:51 EST
Brad, this may already be fixed, could you update the bug if so?
Comment 9 Brad P. Crochet 2016-02-05 18:38:32 EST
This doesn't appear to be fixed as of yet. I am looking for a workaround.
Comment 10 Takuma Umeya 2016-02-15 04:05:54 EST
Still hasn't been fully approved for OSP8; no fix yet.
Comment 14 Alexander Chuzhoy 2016-03-14 17:04:36 EDT
Verified:
Environment:
openstack-tripleo-heat-templates-0.8.10-2.el7ost.noarch

The reported issue doesn't reproduce.

Overcloud Endpoint: http://192.168.0.19:5000/v2.0                                                      
Overcloud Deployed 


And was able to login as heat-admin to all OC nodes.
Comment 16 errata-xmlrpc 2016-04-07 17:44:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.