Bug 1295997 - Need add ETCD_WAL_DIR to default etcd.conf
Need add ETCD_WAL_DIR to default etcd.conf
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: etcd (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jan Chaloupka
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-05 23:00 EST by Joy Pu
Modified: 2016-01-08 03:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 21:23:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joy Pu 2016-01-05 23:00:42 EST
As we put all flags to etcd.conf, so maybe it is better to add the new one wal-d
ir too as a comments in the file

Version-Release number of selected component (if applicable):
etcd-2.2.2-5.el7.x86_64


How reproducible:
100%


Steps to Reproduce:
1. Get etcd --help
$ etcd --help
2. Compare the flags with the flags we get from etcd.conf
3. The --wal-dir is only exist from etcd --help output

Actual results:
etcd.conf miss a flag can be get from etcd --help

Expected results:
etcd.conf should cover all flags get from etcd --help
Comment 2 Jan Chaloupka 2016-01-06 02:11:53 EST
Do you mean ETCD_WAL_DIR env?

$ cat etcd.conf | grep -n WAL
4:#ETCD_WAL_DIR=""
11:#ETCD_MAX_WALS="5"
Comment 3 Joy Pu 2016-01-07 21:23:08 EST
Hi Jan

Double checked the file and flags in another machine. Seems this is caused by unclean test env. Sorry about this.

Retest it again. And find that this flag is in the etcd.conf. But etcd --help is missing a flag --strict-reconfig-check. So will close this one.
Comment 4 Jan Chaloupka 2016-01-08 03:14:10 EST
Thanks Joy for verifying. 

--strict-reconfig-check flag does not exist in etcd-2.2.2. It got into config file by accident. However, it is commented out. The option was added in [1] commit.

[1] https://github.com/coreos/etcd/commit/78791f81a6abd150d99ff2aa88752806fb5c6f1b

Note You need to log in before you can comment on or make changes to this bug.