Bug 1296008 - 503 header is missing in response when try to access a non-exist route
503 header is missing in response when try to access a non-exist route
Status: CLOSED DUPLICATE of bug 1283952
Product: OpenShift Container Platform
Classification: Red Hat
Component: Networking (Show other bugs)
3.1.0
All Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ram Ranganathan
Meng Bo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 01:32 EST by Qi Yong
Modified: 2016-05-11 18:52 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-07 17:41:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qi Yong 2016-01-06 01:32:06 EST
Description of problem:
503 header is missing in response when try to access a non-exist route

Version-Release number of selected component (if applicable):
3.1

How reproducible:
[root@ose31-master ~]# curl -vv foo.example.com
* About to connect() to foo.example.com port 80 (#0)
*   Trying 10.66.219.224...
* Connected to foo.example.com (10.66.219.224) port 80 (#0)
> GET / HTTP/1.1
> User-Agent: curl/7.29.0
> Host: foo.example.com
> Accept: */*
> 
<html><body><h1>503 Service Unavailable</h1>
No server available to handle the request.
</body></html>
* Connection #0 to host foo.example.com left intact


Steps to Reproduce:
1. curl a non-exist route
2.
3.

Actual results:
[root@ose31-master ~]# curl -vv foo.example.com
* About to connect() to foo.example.com port 80 (#0)
*   Trying 10.66.219.224...
* Connected to foo.example.com (10.66.219.224) port 80 (#0)
> GET / HTTP/1.1
> User-Agent: curl/7.29.0
> Host: foo.example.com
> Accept: */*
> 
<html><body><h1>503 Service Unavailable</h1>
No server available to handle the request.
</body></html>
* Connection #0 to host foo.example.com left intact

Expected results:
* About to connect() to cakephp-example-case.router.default.svc.cluster.local port 80 (#0)
*   Trying 10.66.219.224...
* Connected to cakephp-example-case.router.default.svc.cluster.local (10.66.219.224) port 80 (#0)
> GET / HTTP/1.1
> User-Agent: curl/7.29.0
> Host: cakephp-example-case.router.default.svc.cluster.local
> Accept: */*
> 
* HTTP 1.0, assume close after body
< HTTP/1.0 503 Service Unavailable
< Cache-Control: no-cache
< Connection: close
< Content-Type: text/html
< 
<html><body><h1>503 Service Unavailable</h1>
No server is available to handle this request.
</body></html>
* Closing connection 0

Additional info:
When you create a application, deleting rc, pod, svc then curl the route, you could find 503 is in the header in response which is the expected result of customer.
Comment 1 Ram Ranganathan 2016-01-07 17:41:37 EST

*** This bug has been marked as a duplicate of bug 1283952 ***

Note You need to log in before you can comment on or make changes to this bug.