Bug 1296043 - Wrong usage of dict functions
Wrong usage of dict functions
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: core (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 04:36 EST by Pranith Kumar K
Modified: 2017-03-27 14:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.9.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-27 14:15:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2016-01-06 04:36:24 EST
Description of problem:
It seems like two ways to create dictionary is causing problems. There are quite a few dict_new()/dict_destroy() or get_new_dict()/dict_unref() in the code base. So we should stop exposing the functions without ref/unref i.e. get_new_dict()/dict_destroy().

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2016-01-06 04:37:37 EST
REVIEW: http://review.gluster.org/13183 (dict: Don't expose get_new_dict/dict_destroy) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2016-03-01 05:06:03 EST
REVIEW: http://review.gluster.org/13183 (dict: Don't expose get_new_dict/dict_destroy) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Mike McCune 2016-03-28 19:18:47 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Vijay Bellur 2016-06-24 07:43:48 EDT
REVIEW: http://review.gluster.org/13183 (dict: Don't expose get_new_dict/dict_destroy) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Vijay Bellur 2016-06-29 03:10:57 EDT
REVIEW: http://review.gluster.org/13183 (dict: Don't expose get_new_dict/dict_destroy) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 6 Vijay Bellur 2016-07-18 05:29:14 EDT
REVIEW: http://review.gluster.org/13183 (dict: Don't expose get_new_dict/dict_destroy) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 7 Vijay Bellur 2016-07-18 23:24:22 EDT
REVIEW: http://review.gluster.org/13183 (dict: Don't expose get_new_dict/dict_destroy) posted (#6) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 8 Vijay Bellur 2016-07-21 22:13:59 EDT
REVIEW: http://review.gluster.org/13183 (dict: Don't expose get_new_dict/dict_destroy) posted (#7) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 9 Vijay Bellur 2016-07-26 02:47:36 EDT
COMMIT: http://review.gluster.org/13183 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit d2bd17e5a53d0ffa375df1a5ad957556be2f2b83
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Wed Jan 6 14:30:08 2016 +0530

    dict: Don't expose get_new_dict/dict_destroy
    
    get_new_dict/dict_destroy is causing confusion where, dict_new/dict_destroy or
    get_new_dict/dict_unref are used instead of dict_new/dict_unref.
    
    Change-Id: I4cc69f5b6711d720823395e20fd624a0c6c1168c
    BUG: 1296043
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/13183
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
Comment 10 Shyamsundar 2017-03-27 14:15:34 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.9.0, please open a new bug report.

glusterfs-3.9.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2016-November/029281.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.