Bug 1296049 - Support ssh-keygen of OpenSSH 6.8
Support ssh-keygen of OpenSSH 6.8
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
6.0 (Juno)
x86_64 Linux
low Severity low
: ---
: 6.0 (Juno)
Assigned To: Lee Yarwood
Prasanth Anbalagan
: Triaged, ZStream
Depends On:
Blocks: 1296050 1296052
  Show dependency treegraph
 
Reported: 2016-01-06 04:55 EST by Lee Yarwood
Modified: 2016-04-26 21:19 EDT (History)
11 users (show)

See Also:
Fixed In Version: openstack-nova-2014.2.3-50.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1296050 1296052 (view as bug list)
Environment:
Last Closed: 2016-02-22 07:33:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Yarwood 2016-01-06 04:55:25 EST
Description of problem:

The lack of support for openssh 6.8 in Icehouse and Juno results in unit tests failing when ran on Fedora based development hosts. Though RHEL OSP does not formally support Fedora it would be useful to backport the following change to allow developers to run tests locally.

Support ssh-keygen of OpenSSH 6.8
https://review.openstack.org/#/c/191847/

Version-Release number of selected component (if applicable):
openstack-nova-2014.1.5-9
openstack-nova-2014.2.3-42

How reproducible:
Always.

Steps to Reproduce:
1. Run unit tests on a host with openssh >= 6.8

Actual results:

The following unit tests will fail (note paths may vary between versions) :

nova.tests.unit.api.ec2.test_cloud.CloudTestCase.test_import_key_pair
nova.tests.unit.compute.test_keypairs.ImportKeypairTestCase.test_success_ssh

Expected results:

No unit tests fail.

Additional info:
Comment 6 errata-xmlrpc 2016-02-22 07:33:25 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0283.html

Note You need to log in before you can comment on or make changes to this bug.