Bug 129608 - Install to RAID1 (Mirror) fails if mirror is not synced before reboot
Install to RAID1 (Mirror) fails if mirror is not synced before reboot
Status: CLOSED DUPLICATE of bug 116685
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-10 16:47 EDT by Simon Jones
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Jones 2004-08-10 16:47:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040626 Firefox/0.9.1

Description of problem:
When installing FC3T1 and using software raid1, if the installer
finishes before the mirror sync's, then when the reboot occurs the
system will fail to boot.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Start install of FC3 T1, create a big software raid 1 array
2.let installer install a typical 2.2G install
3.let the installer reboot as soon as installed
    

Actual Results:  System refuses to boot

Expected Results:  System would boot normally.

Additional info:

Can anaconda be modified to know when the raid is sync'd and then
allow a reboot, i.e at the end of the install put a notice on screen
showing the raid is syncing.. please wait...

Work around is to look at the log as it installs and wait for the
mirror to be synced then reboot.
Comment 1 Jeremy Katz 2004-08-10 17:15:49 EDT
This is a kernel bug.  The kernel shouldn't mark an array as finished
syncing on boot if it's not actually.

*** This bug has been marked as a duplicate of 116685 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.