Bug 1296094 - Without vhost=on, during netperf w/ protocol UDP_STREAM in guest, this guest can not response other thing
Without vhost=on, during netperf w/ protocol UDP_STREAM in guest, this guest ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.8
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: jason wang
Virtualization Bugs
:
Depends On:
Blocks: 1359965
  Show dependency treegraph
 
Reported: 2016-01-06 05:21 EST by weliao
Modified: 2017-12-06 05:19 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-12-06 05:19:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description weliao 2016-01-06 05:21:17 EST
Description of problem:
Boot a rhel6.8 guest w/ a virtio-net-pci device, but w/o vhost=on, when test netperf and protocol UDP_STREAM inside guest, during the stress, guest can not response any other things, such as click mouse, input keys ...
If boot w/vhost=off,sndbuf=1048576,won't hit this issue.
If boot w/ vhost=on, won't hit this problem.

Version-Release number of selected component (if applicable):
2.6.32-595.el6.x86_64
qemu-kvm-0.12.1.2-2.483.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Boot a rhel6.8 guest w/ virtio-net-pci device but do not add option vhost=on.
2.In any external host run a netserver, and in this guest test nerperf w/ protocol UDP_STREAM
# netperf -H 10.66.9.230 -t UDP_STREAM -l 30
3.On the spice window, try to type or click or send ctrl-alt-f2  

Actual results:
From the spice window(w/ GUI), can not do anything, seams lose response.

Expected results:
guest works well 

Additional info:
/usr/libexec/qemu-kvm \
-name rhel6.8 -machine pc  \
-drive id=drive_image1,if=none,cache=none,snapshot=on,format=qcow2,file=/mnt/RHEL-Server-6.7-64-virtio.qcow2 \
-device virtio-blk-pci,id=image1,drive=drive_image1,bus=pci.0,bootindex=0 \
-netdev tap,id=hostnet0,vhost=off \
-device virtio-net-pci,netdev=hostnet0,mac=52:56:25:93:79:66,id=net0,status=on,ioeventfd=on  \
-m 4096 \
-smp 4,maxcpus=8,cores=4,threads=1,sockets=1 \
-cpu SandyBridge \
-boot menu=on -enable-kvm \
-qmp tcp:0:5555,nowait,server \
-monitor stdio \
-spice port=5900,disable-ticketing \
-global qxl-vga.vram_size=67108864 \
-vga qxl \
-chardev socket,path=/tmp/qga.sock,server,nowait,id=qga0 \
-device virtio-serial -device virtserialport,chardev=qga0,name=org.qemu.guest_agent.0
Comment 3 jason wang 2016-01-07 21:47:50 EST
What qdisc did you use in guest?

This is probably a known issue since no tx completion interrups for virtio-net.
Comment 9 jason wang 2016-10-25 22:09:06 EDT
Defer to 6.10. Well known issues upstream if using a non fair queuing qdisc in host or guest tx buffer bloat.
Comment 11 Jan Kurik 2017-12-06 05:19:21 EST
Red Hat Enterprise Linux 6 is in the Production 3 Phase. During the Production 3 Phase, Critical impact Security Advisories (RHSAs) and selected Urgent Priority Bug Fix Advisories (RHBAs) may be released as they become available.

The official life cycle policy can be reviewed here:

http://redhat.com/rhel/lifecycle

This issue does not meet the inclusion criteria for the Production 3 Phase and will be marked as CLOSED/WONTFIX. If this remains a critical requirement, please contact Red Hat Customer Support to request a re-evaluation of the issue, citing a clear business justification. Note that a strong business justification will be required for re-evaluation. Red Hat Customer Support can be contacted via the Red Hat Customer Portal at the following URL:

https://access.redhat.com/

Note You need to log in before you can comment on or make changes to this bug.