Bug 1296095 - gdata-sharp FTBFS on Rawhide because of changes to nunit
gdata-sharp FTBFS on Rawhide because of changes to nunit
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gdata-sharp (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
: 1307522 (view as bug list)
Depends On:
Blocks: F24FTBFS 1220138
  Show dependency treegraph
 
Reported: 2016-01-06 05:22 EST by Timotheus Pokorra
Modified: 2016-10-14 05:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-14 05:20:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
now it finds nunit.framework.dll (1.83 KB, application/mbox)
2016-01-06 05:22 EST, Timotheus Pokorra
no flags Details

  None (edit)
Description Timotheus Pokorra 2016-01-06 05:22:35 EST
Created attachment 1112060 [details]
now it finds nunit.framework.dll

I noticed that gdata-sharp fails to build from source on Rawhide.

I am attaching a patch that fixes the problem.

for the full logs see http://koji.fedoraproject.org/koji/taskinfo?taskID=12433698

the tail of that log:
mcs -out:gbase_queryexample.exe -r:Google.GData.Calendar.dll -r:Google.GData.Client.dll -r:Google.GData.CodeSearch.dll -r:Google.GData.Extensions.dll -r:Google.GData.GoogleBase.dll -r:Google.GData.Spreadsheets.dll -r:Google.GData.Apps.dll -r:Google.GData.Photos.dll -r:Google.GData.Documents.dll -r:Google.GData.AccessControl.dll -r:Google.GData.Contacts.dll -r:Google.GData.YouTube.dll -r:Google.GData.Health.dll -r:Google.GData.Blogger.dll -r:System.dll -r:System.Xml.dll -r:System.Web.dll -r:System.Configuration.dll samples/gbase/example.cs samples/gbase/queryexample.cs
mcs -out:gbase_customertool.exe -r:Google.GData.Calendar.dll -r:Google.GData.Client.dll -r:Google.GData.CodeSearch.dll -r:Google.GData.Extensions.dll -r:Google.GData.GoogleBase.dll -r:Google.GData.Spreadsheets.dll -r:Google.GData.Apps.dll -r:Google.GData.Photos.dll -r:Google.GData.Documents.dll -r:Google.GData.AccessControl.dll -r:Google.GData.Contacts.dll -r:Google.GData.YouTube.dll -r:Google.GData.Health.dll -r:Google.GData.Blogger.dll -r:System.dll -r:System.Xml.dll -r:System.Web.dll -r:System.Configuration.dll samples/gbase/example.cs samples/gbase/customertool.cs samples/gbase/commands.cs
mcs -out:execrequest.exe -r:Google.GData.Calendar.dll -r:Google.GData.Client.dll -r:Google.GData.CodeSearch.dll -r:Google.GData.Extensions.dll -r:Google.GData.GoogleBase.dll -r:Google.GData.Spreadsheets.dll -r:Google.GData.Apps.dll -r:Google.GData.Photos.dll -r:Google.GData.Documents.dll -r:Google.GData.AccessControl.dll -r:Google.GData.Contacts.dll -r:Google.GData.YouTube.dll -r:Google.GData.Health.dll -r:Google.GData.Blogger.dll -r:System.dll -r:System.Xml.dll -r:System.Web.dll -r:System.Configuration.dll samples/execrequest/main.cs samples/execrequest/AssemblyInfo.cs
error CS0006: Metadata file `nunit.framework.dll' could not be found
Compilation failed: 1 error(s), 0 warnings
Makefile:131: recipe for target 'tests' failed
make: *** [tests] Error 1
make: *** Waiting for unfinished jobs....
RPM build errors:
error: Bad exit status from /var/tmp/rpm-tmp.x94niV (%build)
    Bad exit status from /var/tmp/rpm-tmp.x94niV (%build)
Child return code was: 1
EXCEPTION: Command failed. See logs for output.
 # bash --login -c /usr/bin/rpmbuild -bb --target x86_64 --nodeps  /builddir/build/SPECS/gdata-sharp.spec 
Traceback (most recent call last):
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 84, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.4/site-packages/mockbuild/util.py", line 526, in do
    raise exception.Error("Command failed. See logs for output.\n # %s" % (command,), child.returncode)
mockbuild.exception.Error: Command failed. See logs for output.
 # bash --login -c /usr/bin/rpmbuild -bb --target x86_64 --nodeps  /builddir/build/SPECS/gdata-sharp.spec 
LEAVE do --> EXCEPTION RAISED
Comment 1 Jan Kurik 2016-02-24 09:14:13 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 2 Timotheus Pokorra 2016-10-13 14:59:06 EDT
*** Bug 1307522 has been marked as a duplicate of this bug. ***
Comment 3 Timotheus Pokorra 2016-10-13 15:05:40 EDT
my patch might not work anymore, now that NUnit 3 is in rawhide. Perhaps the package now needs to depend on nunit2. I would be happy to get commit privileges and to fix it.
Comment 4 Timotheus Pokorra 2016-10-14 05:20:08 EDT
Peter Robinson has applied the fixes to the package, in the work for Mono in aarch64 for Fedora 26. So this is fixed now.

Note You need to log in before you can comment on or make changes to this bug.