Bug 1296110 - Restore all the title handling options
Restore all the title handling options
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-terminal (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Debarshi Ray
Desktop QE
Lucie Maňásková
: FutureFeature
Depends On:
Blocks: 1203710 1297830 1313485
  Show dependency treegraph
 
Reported: 2016-01-06 06:02 EST by amit yadav
Modified: 2016-11-03 19:48 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Custom titles for the terminal tabs or windows This update allows users to set custom titles for terminal windows or tabs in *gnome-terminal*. The titles can be changed directly in the *gnome-terminal* user interface.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:48:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 740188 None None None 2016-05-25 06:01 EDT

  None (edit)
Description amit yadav 2016-01-06 06:02:51 EST
1. What is the nature and description of the request?

The request is to include 'Title' option support for gnome-terminal windows and tabs similar to what was available in older versions of gnome-terminal as available in RHEL prior to the RHEL7.2 release.

Previous versions of gnome-terminal prior to RHEL 7.2 allowed titles to be set in terminal windows and tabs with the --title option.  It was also possible to set the title on a tab by performing a right-click on a tab and selecting the 'Set Title...' option.  In addition, there was also a preserve title feature that could be set via the gnome-terminal "Profile Preferences" --> "Title and Command" --> "Title: Keep initial title" selection.  This was useful in conjunction with --title in many circumstances.


2. Why would you need it ? (List the business requirements here)

Used in various combinations these 3 options can address terminal managment in many situations.  The above options all helped to effectively manage a large number of terminal widows/tabs over multiple workspaces.   The --title option was very useful for defining predefined window/tab sets for a large number of systems and various activities.  The right-click set title option allowed one to easily rename a tab with a running process so it could easily be identified, found, and tracked or to avoid accidental closure.  There appears to be no viable title alternative for these use cases.  Sysetem Administrators and others are often working with dozens (and dozens and dozens) of terminal windows and tabs.  The system terminal is a critical application in Linux/UNIX environments especially in an enterprise environment.  To perform an operation in the wrong terminal window/tab can be catastrophic.


3. How would you like to achieve this? (List the functional requirements here)

Ideally restoration of title features as found in gnome-terminal prior to the release of RHEL 7.2 (i.e., gnome-terminal-3.8.4-8.el7 or earlier).  Any of the features are better than none but ideally all the title features would be restored include the profile feature related to titles.


4. For each functional requirement listed, specify how Red Hat and you can test to confirm the requirement is successfully implemented.

The '--title' option can be tested with a code block like the following:

#!/usr/bin/bash
/usr/bin/gnome-terminal --window --geometry=132x40 --profile='default' --title='host1' \
--tab --profile='site.tpreserve' --title=host2 \
--tab --profile='site.tpreserve' --title=host3 \
--tab --profile='site.tpreserve' --title=host4

The right-click 'set title' option on a tab can be tested as described above.


5. Do you have any specific timeline dependencies ?

No


6. Is the sales team involved in this request and do they have any additional input?

No


7. Would you be able to assist in testing this functionality if implemented? 

Yes


Additional details:

Gnome rebase to 3.14 must have done this,
https://bugzilla.gnome.org/show_bug.cgi?id=724110
https://bugzilla.gnome.org/show_bug.cgi?id=740188
Comment 2 Matthias Clasen 2016-04-05 10:31:10 EDT
Here is the upstream commit to backport:

https://git.gnome.org/browse/gnome-terminal/commit/?id=156b85533f42d8c7e6cf6258ce3e7fe4ec8f1754
Comment 3 Debarshi Ray 2016-04-11 14:48:26 EDT
I have built gnome-terminal-3.14.3-7.el7:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=10830606
Comment 6 Matthias Clasen 2016-04-12 12:18:36 EDT
The option is still deprecated, so the warning is intentional, but it is working again.
Comment 16 Debarshi Ray 2016-06-30 14:48:58 EDT
I have built gnome-terminal-3.14.3-12.el7:
https://brewweb.engineering.redhat.com/brew/taskinfo?taskID=11293633

It should have all the knobs that were there in RHEL 7.1 (ie. till GNOME 3.10.x).
Comment 20 errata-xmlrpc 2016-11-03 19:48:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2167.html

Note You need to log in before you can comment on or make changes to this bug.