Bug 1296115 - Server fails to start when data-roles-required is defined
Server fails to start when data-roles-required is defined
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.3.0
Unspecified Unspecified
high Severity urgent
: ER1
: 6.3.0
Assigned To: Van Halbert
Andrej Smigala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 06:15 EST by Andrej Smigala
Modified: 2016-08-24 07:49 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:49:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-3419 Major Resolved Add ability to set a default role across all VDBs 2016-07-01 10:46 EDT

  None (edit)
Description Andrej Smigala 2016-01-06 06:15:50 EST
When the data-roles-required is defined in standalone.xml, starting the server fails with the following error:

12:02:11,240 ERROR [org.jboss.as.server] (Controller Boot Thread) JBAS015956: Caught exception during boot: org.jboss.as.controller.persistence.ConfigurationPersistenceException: JBAS014676: Failed to parse configuration
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:141) [jboss-as-controller-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.server.ServerService.boot(ServerService.java:336) [jboss-as-server-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.controller.AbstractControllerService$1.run(AbstractControllerService.java:263) [jboss-as-controller-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
        at java.lang.Thread.run(Thread.java:745) [rt.jar:1.8.0_65]
Caused by: javax.xml.stream.XMLStreamException: ParseError at [row,col]:[510,13]
Message: JBAS014789: Unexpected element '{urn:jboss:domain:teiid:1.0}data-roles-required' encountered
        at org.jboss.as.controller.parsing.ParseUtils.unexpectedElement(ParseUtils.java:86) [jboss-as-controller-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
        at org.teiid.jboss.TeiidSubsystemParser.readElement(TeiidSubsystemParser.java:339)
        at org.teiid.jboss.TeiidSubsystemParser.readElement(TeiidSubsystemParser.java:43)
        at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-3.jar:1.1.0.Final-redhat-3]
        at org.jboss.staxmapper.XMLExtendedStreamReaderImpl.handleAny(XMLExtendedStreamReaderImpl.java:69) [staxmapper-1.1.0.Final-redhat-3.jar:1.1.0.Final-redhat-3]
        at org.jboss.as.server.parsing.StandaloneXml.parseServerProfile(StandaloneXml.java:1094) [jboss-as-server-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.server.parsing.StandaloneXml.readServerElement_1_4(StandaloneXml.java:469) [jboss-as-server-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:145) [jboss-as-server-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
        at org.jboss.as.server.parsing.StandaloneXml.readElement(StandaloneXml.java:107) [jboss-as-server-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
        at org.jboss.staxmapper.XMLMapperImpl.processNested(XMLMapperImpl.java:110) [staxmapper-1.1.0.Final-redhat-3.jar:1.1.0.Final-redhat-3]
        at org.jboss.staxmapper.XMLMapperImpl.parseDocument(XMLMapperImpl.java:69) [staxmapper-1.1.0.Final-redhat-3.jar:1.1.0.Final-redhat-3]
        at org.jboss.as.controller.persistence.XmlConfigurationPersister.load(XmlConfigurationPersister.java:133) [jboss-as-controller-7.5.3.Final-redhat-2.jar:7.5.3.Final-redhat-2]
        ... 3 more

12:02:11,243 FATAL [org.jboss.as.server] (Controller Boot Thread) JBAS015957: Server boot has failed in an unrecoverable manner; exiting. See previous messages for details.
Comment 2 JBoss JIRA Server 2016-01-06 07:33:24 EST
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-3419 to Resolved

Note You need to log in before you can comment on or make changes to this bug.