Bug 1296127 - string showing number of cores of VM in basictab in 3.6 is harder to read than in 3.5
string showing number of cores of VM in basictab in 3.6 is harder to read tha...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: Frontend.UserPortal (Show other bugs)
3.6.0
Unspecified Unspecified
low Severity low (vote)
: ovirt-4.0.2
: 4.0.2.1
Assigned To: Marek Libra
movciari
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 07:05 EST by movciari
Modified: 2016-07-26 09:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-26 06:42:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑4.0.z+
rule-engine: planning_ack+
tjelinek: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 54995 master MERGED webadmin: Tooltip for cpuInfo 2016-04-06 05:57 EDT
oVirt gerrit 60079 master MERGED webadmin: Tooltip for cpuInfo 2016-07-21 07:08 EDT
oVirt gerrit 60081 ovirt-engine-4.0 MERGED webadmin: Tooltip for cpuInfo 2016-07-21 07:08 EDT

  None (edit)
Description movciari 2016-01-06 07:05:40 EST
Description of problem:
In userportal basictab in 3.5, for number of cores of VM, you can see:
Number of cores: 1 (1 Socket(s), 1 Core(s) per Socket)
very simple, understandable and easy to read for everyone, even the most basic users
In 3.6, there's this:
Number of cores: 1 (1:1:1 Sockets:Cores/Sckt:Threads/Sckt)
which actually makes people read it 3 times skipping between 1:1:1 and its explanation for each number, and leaves some people wondering what "Sckt" means at least for a few seconds.
Text in 3.5 was much easier to read,

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. visit userportal basictab with a user that can see some VM
2. select a VM
3. check text for number of cores

Additional info:
if text is too long with threads per socket, it should at least have a tooltip with the original long but easy to read text
Comment 1 Michal Skrivanek 2016-03-16 03:43:20 EDT
I would change that to "Number of cores: 1 (1:1:1)(?)" with a tooltip providing full sentence with explanation
Comment 2 Marek Libra 2016-03-21 12:11:00 EDT
Implemented as a tooltip when the mouse pointer is over the value.
Comment 3 Mike McCune 2016-03-28 19:07:19 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 movciari 2016-06-30 08:05:28 EDT
The tooltip is almost fine as it contains all the info, but now there's inconsistency between general subtab of VM and sub-subtabs:
Go to snapshots subtab and select a snapshot, on the right part of subtab you will see general sub-subtab, which still shows:
"1 (1:1:1 Sockets:Cores/S.:Threads/C.)"
and it doesn't have a tooltip
Comment 5 Red Hat Bugzilla Rules Engine 2016-06-30 08:05:33 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Red Hat Bugzilla Rules Engine 2016-07-21 07:09:15 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 7 Lukas Svaty 2016-07-26 06:42:44 EDT
This bug was fixed and is slated to be in the upcoming version. As we
are focusing our testing at this phase on severe bugs, this bug was
closed without going through its verification step. If you think this
bug should be verified by QE, please set its severity to high and move
it back to ON_QA

Note You need to log in before you can comment on or make changes to this bug.