Bug 1296154 - Firefox uses crazy illegible fonts for Disqus discussion when it should use Georgia
Firefox uses crazy illegible fonts for Disqus discussion when it should use G...
Status: CLOSED UPSTREAM
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: firefox (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Stransky
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 08:30 EST by Matěj Cepl
Modified: 2016-02-29 09:34 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:34:45 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of the Firefox inspector showing the problem (235.42 KB, image/png)
2016-01-06 08:30 EST, Matěj Cepl
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 1167284 None None None 2016-02-29 09:34 EST

  None (edit)
Description Matěj Cepl 2016-01-06 08:30:27 EST
Created attachment 1112160 [details]
screenshot of the Firefox inspector showing the problem

Description of problem:
When entering the Disqus discussion on http://www.firstthings.com/web-exclusives/2016/01/free-university-orthodoxy (I am not sure how to save this page so that we would have attached here reproduction data set) the comment text is in fact displayed with "Nimbus Roman No9" Type1 font (see attached screenshot of the Firefox inspector on the page) when the Computed font-family is "Georgia,Times,serif".

However, when I run

fc-match Georgia

on the command line, I get

DejaVuSerif.ttf: "DejaVu Serif" "Book"

which is a way more useful suggestion. Why Firefox doesn't follow fontconfig, where is the problem?

Version-Release number of selected component (if applicable):
Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Firefox/38.0


How reproducible:
100% on my computer

Steps to Reproduce:
1.open the page and activate Disqus comments
2.
3.

Actual results:
using hard to read Nimbus Type1 font instead of antialiased nice TrueType DejaVu Serif.
Comment 2 Matěj Cepl 2016-01-06 09:29:44 EST
Adding this to /etc/fonts/local.conf made the problem go away:

<alias>
    <family>Georgia</family>
    <accept>
      <family>DejaVu Serif</family>
    </accept>
</alias>

But it is not right, because fc-match was saying the same before already. Why Firefox does not give the same answer as fc-match?
Comment 3 Matěj Cepl 2016-01-06 09:32:52 EST
BTW, using firefox from the package firefox-38.5.0-3.el7_2.x86_64

Actually I was wrong in the comment 1 ... this local.conf modification helped to the upstream binary for Aurora (Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0), but our RHEL Firefox 38.5.0 still manifests the same issue (Font inspector shows Nimbus font and it really looks like Type1 non-antialiased font).
Comment 4 Martin Stransky 2016-02-29 09:34:45 EST
AFAIK ti may be fixed by https://bugzilla.mozilla.org/show_bug.cgi?id=1167284
Please reopen if you see that in ESR45.

Note You need to log in before you can comment on or make changes to this bug.