Bug 1296206 - Geo-Replication Session goes "FAULTY" when application logs rolled on master
Geo-Replication Session goes "FAULTY" when application logs rolled on master
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
All Linux
high Severity high
: ---
: ---
Assigned To: Milind Changire
: ZStream
Depends On: 1264986 1296208
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 10:29 EST by Milind Changire
Modified: 2016-06-16 09:53 EDT (History)
10 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1264986
Environment:
Last Closed: 2016-06-16 09:53:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2016-01-06 11:03:10 EST
REVIEW: http://review.gluster.org/13186 (geo-rep: avoid creating multiple entries with same gfid) posted (#2) for review on master by Milind Changire (mchangir@redhat.com)
Comment 2 Vijay Bellur 2016-01-06 12:22:16 EST
REVIEW: http://review.gluster.org/13186 (geo-rep: avoid creating multiple entries with same gfid) posted (#3) for review on master by Milind Changire (mchangir@redhat.com)
Comment 3 Vijay Bellur 2016-01-07 01:29:45 EST
REVIEW: http://review.gluster.org/13186 (geo-rep: avoid creating multiple entries with same gfid) posted (#4) for review on master by Milind Changire (mchangir@redhat.com)
Comment 4 Milind Changire 2016-01-08 01:53:23 EST
Public comments:
The issue manifest when nightly logs are rolled over by customer application using log4j.

Investigation revealed that there is an issue with CREATE + RENAME log replay from geo-rep.

Patch http://review.gluster.org/13186 is available to resolve the issue.
Comment 5 Vijay Bellur 2016-01-29 03:28:25 EST
REVIEW: http://review.gluster.org/13316 (georep: avoid creating multiple entries with same gfid) posted (#1) for review on master by Milind Changire (mchangir@redhat.com)
Comment 6 Vijay Bellur 2016-03-01 02:58:10 EST
COMMIT: http://review.gluster.org/13316 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit 87d93fac9fcc4b258b7eb432ac4151cdd043534f
Author: Milind Changire <mchangir@redhat.com>
Date:   Fri Jan 29 13:53:07 2016 +0530

    georep: avoid creating multiple entries with same gfid
    
    Problem:
    CREATE + RENAME changelogs replayed by geo-replication cause
    stale old-name entries with same gfid on slave nodes.
    A gfid is a unique key in the file-system and should not be
    assigned to multiple entries.
    
    Solution:
    Create entry on slave only if lstat(gfid) at aux-mount fails.
    This applies to files as well as directories.
    
    Change-Id: Ice3340f4ae1251c2dcef024a2388c4d33b5d4919
    BUG: 1296206
    Signed-off-by: Milind Changire <mchangir@redhat.com>
    Reviewed-on: http://review.gluster.org/13316
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Aravinda VK <avishwan@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
Comment 7 Mike McCune 2016-03-28 19:03:07 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 8 Niels de Vos 2016-06-16 09:53:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.