Bug 1296215 - error messages have lack of information
error messages have lack of information
Status: CLOSED WONTFIX
Product: Red Hat Storage Console
Classification: Red Hat
Component: core (Show other bugs)
2
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 2
Assigned To: Nishanth Thomas
sds-qe-bugs
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 10:46 EST by Martin Kudlej
Modified: 2016-03-22 04:38 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-10 04:36:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
skyring console log (2.37 KB, text/plain)
2016-01-20 04:52 EST, Martin Bukatovic
no flags Details

  None (edit)
Description Martin Kudlej 2016-01-06 10:46:44 EST
Description of problem:
Cluster creation task failed and all I see in log is this:
ESC[36m2016-01-06T16:16:27.483+01:00 DEBUG    cluster.go:173 POST_Clusters]ESC[0m Task Created: %!(EXTRA string=7e5d3e38-03f8-4752-8be0-b80cf1793290)
[negroni] Completed 202 Accepted in 4.131344ms
ESC[31m2016-01-06T16:16:27.487+01:00 ERROR    utils.go:133 FailTask]ESC[0m Cluster creation failed: CreateCluster(): function failed at python side

Error message does not contain any information which can describe reason why cluster creation has failed. I think ERRORs should contain more information.

Version-Release number of selected component (if applicable):
rhscon-core-0.0.5-0.1.alpha1.el7.x86_64
rhscon-ceph-0.0.3-0.1.alpha1.el7.x86_64
rhscon-ui-0.0.3-0.1.alpha1.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. try to create something which leads to error in log
2. check amount of information in error message

Actual results:
There is not enough information in cluster creation error.

Expected results:
There is enough information to identify reason in all errors.
Comment 1 Martin Bukatovic 2016-01-20 04:52 EST
Created attachment 1116562 [details]
skyring console log

Additional information
======================

I hit this issue again. On the Tasks page I see that the following task failed:

> Create Cluster: cluster01
> 09d6820f-c4f9-4910-a49e-5bfbec6afce2

See excerpt from skyring console log which start with the 1st mention
of this task and ends with the last.

File /var/log/skyring/bigfin.log doesn't contain more details either:

~~~
2016-01-20T10:26:11.515+01:00 ERROR    utils.go:133 FailTask] Cluster creation failed: CreateCluster(): function failed at python side
~~~

File /var/log/salt/master is empty on usm server machine.

The problem is that there are no useful information provided by usm server,
the only option is to manually check nodes which is hardly optimal.
Comment 2 Nishanth Thomas 2016-02-03 02:55:06 EST
Sounds duplicate to 1300656. How does it differ?
Comment 3 Martin Bukatovic 2016-02-04 04:26:46 EST
(In reply to Nishanth Thomas from comment #2)
> Sounds duplicate to 1300656. How does it differ?

Those are completely separate, but related issues.

See the description of BZ 1300656:

> This BZ is concerned with *the fact that the create cluster operation fails* in
> this way every now and then. There is another BZ 1296215 which deals with the
> fact that there is no good evidence what actually happens in similar cases.

In other words:

 * BZ 1296215 (this BZ) is about missing information in the logs when any
   failure on a python side happens
 * BZ 1300656 is about one particular failure of "Create Cluster" task
Comment 5 RHEL Product and Program Management 2016-03-10 04:36:12 EST
Development Management has reviewed and declined this request.
You may appeal this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.