This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1296255 - could not lock client with self-hosted LTS
could not lock client with self-hosted LTS
Status: CLOSED WONTFIX
Product: Red Hat Certification Program
Classification: Red Hat
Component: redhat-certification-hardware (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: brose
Brian Brock
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 12:55 EST by Brian Brock
Modified: 2017-04-18 22:05 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-04-18 22:05:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Brock 2016-01-06 12:55:47 EST
Description of problem:
When running hardware certification tests, if a system is both results server and test system, an error about locking is printed.

Version-Release number of selected component (if applicable):
redhat-certification-2.1-20151221.el7.noarch
redhat-certification-hardware-1.7.1-20151218.el7.noarch


How reproducible:
still checking for workarounds or another cause of the same symptoms.  Seen several times, it seems like there may be an additional condition.

Steps to Reproduce:
1. create a hardware certification from packages on the server, without registering any systems.
2. an error message is printed, explaining that the user must register a system before being able to select it for a cert
3. add the system itself as a test system 
 

Actual results:
The results screen that is loaded next shows an error message immediately below the new hostname:

Error: could not lock client	


Expected results:
no complaint about locking 

Additional info:
Going to the page to launch tests (a single results file), there are no tests listed.
Comment 2 Yaroslav Morkovnikov 2016-05-10 09:39:22 EDT
got the same error, is it possible to overcome?
Comment 3 Yaroslav Morkovnikov 2016-05-10 09:39:36 EDT
got the same error, is it possible to overcome?
Comment 5 Lenny Verkhovsky 2016-07-19 04:19:36 EDT
Got the same error, is it possible to overcome?
Comment 6 brose 2016-07-19 09:31:56 EDT
Please, on the client, try:
$rhcertd stop
$rhcert-backend print (answer yes if it asks to override locks)
$rhcertd start
Comment 7 Lenny Verkhovsky 2016-07-19 09:39:54 EDT
#rhcertd stop

Starting RedHatCertDaemon at 2016-07-19 13:37:13
The rhcert daemon is not running
The rhcert listener is not running
[root@r-dcs81 ~]# rhcert-backend print
No test results or plan to print
[root@r-dcs81 ~]# rhcertd start

Starting RedHatCertDaemon at 2016-07-19 13:37:35
Starting rhcert daemon
Starting rhcert listener

#rhcertd status

Starting RedHatCertDaemon at 2016-07-19 13:39:31
The rhcert daemon is running
The rhcert listener is running


Nothing happens, and I cant open UI.
This site can’t be reached
r-dcs81 took too long to respond.

How can I debug/reinstall rhcert?
Comment 8 Greg Nichols 2016-07-19 10:20:03 EDT
Is httpd running?   Try:
$systemctl restart httpd
Comment 9 Lenny Verkhovsky 2016-07-20 04:09:26 EDT
systemctl start  iptables.service  solved the issue
Comment 10 Lenny Verkhovsky 2016-10-09 03:16:13 EDT
p.s. I've seen same error.

After I've stopped #rhcertd stop 
the lock file remained /var/lock/subsys/rhcert
After I had deleted /var/lock/subsys/rhcert, the issue has gone.

Note You need to log in before you can comment on or make changes to this bug.