Bug 129626 - missing mime types in FC3t1
missing mime types in FC3t1
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-08-10 21:12 EDT by Scott Talbot
Modified: 2007-11-30 17:10 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 09:26:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Talbot 2004-08-10 21:12:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
1) clicking a file in an open window results in error message that
Nautilus couldn't open file.  The message is similar for graphics,
sound and text files.

2) opening File Types preferences ((HAT)->Preferences->File Types and
programs) shows only a short list of mime types all under the heading
of Internet Services. types include http https aim mailto man info
etc. etc.  There are no image-x/xcf or sound-x/mp3 or any other.

I am able to set a particular program to open a file type using the
open with other application in the drop-down box.

Problem showed up Aug 9 after downloading 120 files including
nautilus-2.7.2-1. 

Version-Release number of selected component (if applicable):
3.0-1

How reproducible:
Always

Steps to Reproduce:
1.Open Home Drawer from desktop of gnome, running nautilus
2.click any image file (jpeg etc.)
3.receive error message
    

Actual Results:  recieved error message "Couldn't display whatever.jpg"

Expected Results:  expected nautilus window to display image, or
another application determined by filetype

Additional info:

although at first there were no other problems, (in fact I was very
impressed with how fast Nautilus had become!" now I am getting
frequent crashes within nautilus.  The only thing I did was to attempt
to assign applications to a few file types, the last one before the
crashes, I used the properties window to assign gimp to the filetype
x-/xcf it crashed immediately after that and required a reboot and
have needed to reboot perhaps 3 times since (less than 48 hours)
Comment 1 Aaron Gaudio 2004-08-15 03:48:10 EDT
I'm having this problem as well. In particular, I tried to add a file
type for Gnucash files, with extension .xac. Gnucash uses an XML
format. After adding the file type (which as indicated above, did not
show up in the File Types and Programs capplet), nautilus shows xac
files with what I presume to be the gnucash icon. As soon as I select
the file, however, the icon changes to the XML icon and if I try to
open it, it refuses to even try to use gnucash. Instead, I get a
message saying that file contents and the extension don't match up and
I should use "Open with..."; if I try to use "Open with gnucash",
however, it just pops up the same error dialog.

In gnucash, I set my preferences to store compressed files. Now the
files are gzipped, so nautilus no longer thinks it is an XML file.
However, if I try to open it from nautilus now I just get a message
saying it couldn't load the application (which loads fine from the
command line).
Comment 2 Brian Millett 2004-09-07 12:45:08 EDT
This sounds crazy, but my ((HAT)->Preferences->File Types and
programs) is missing.  What rpm provides this?  I'm using FC3t1 + rawhide
Comment 3 Alexander Larsson 2004-09-08 04:01:57 EDT
That dialog is now gone, and the whole mime system replaced:
http://www.gnome.org/~jrb/files/mime/
Comment 4 Alexander Larsson 2004-10-05 09:26:02 EDT
There has been a lot of fixes to the mime system, and i can't
reproduce the original problem. I'm considering this fixed. If you
have specific issues. Open a new bug.

Note You need to log in before you can comment on or make changes to this bug.