Bug 1296291 - Prepare OPM modules for OSP8
Prepare OPM modules for OSP8
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
8.0 (Liberty)
All Linux
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: Jason Guiditta
Amit Ugol
: Rebase, TestOnly, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 14:52 EST by Emilien Macchi
Modified: 2016-04-28 09:52 EDT (History)
6 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-7.0.4-1.el7ost
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-28 09:52:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Gerrithub.io 258793 None None None 2016-01-07 12:19 EST
Gerrithub.io 258832 None None None 2016-01-07 12:17 EST

  None (edit)
Description Emilien Macchi 2016-01-06 14:52:15 EST
All Puppet modules need to be updated to their upstream.

1/ OpenStack modules
They should all be rebased on top of stable/liberty branch.

2/ All other modules
There are different cases we need to cover:

The module has no release.
https://github.com/redhat-openstack/puppet-pacemaker does not have any release, so let's rebase it on top of master.

The module has releases and is tested by Puppet OpenStack project
https://github.com/puppetlabs/puppetlabs-apache has releases.
If the module is listed on https://github.com/openstack/puppet-openstack-integration/blob/master/Puppetfile - rebase the module to the same version so we're sure we're in sync with upstream CI. By the way, the upstream Puppetfile is very recent and should track latest releases.

The module has releases but is not tested by Puppet OpenStack project
https://github.com/sensu/sensu-puppet has releases but Puppet OpenStack project does not test it, and TripleO test master. So we need to rebase it on top of the last commit in master.
Why not using the latest release? Because sometimes, we have an important commit (from us or somebody else) that is not part of the latest release and we need it in our OPM.
If you feel like we can use the latest release, go for it, otherwise use the latest commit in master.
Comment 1 Jason Guiditta 2016-01-07 08:32:18 EST
Ok, just checked, looks like puppet-pacemaker is good, the commit hash in opm puppetfile matches the latest commit in puppet-pacemaker/master
Comment 2 Jason Guiditta 2016-01-07 08:34:04 EST
puppet-sensu is also a match sensu/master == opm/liberty
Comment 3 Jason Guiditta 2016-01-07 12:39:14 EST
Changes to opm merged.  We have updated fluentd as well. There is some major disparity between the integration repo and what opm currently has for non-openstack modules (opm mostly working from master, no branches), so I think that is too disruptive a change for this update, but we can definitely work toward getting the two in better sync as soon as reasonable.

Note You need to log in before you can comment on or make changes to this bug.