Bug 1296295 - rhel-osp-director: Upgrade of undercloud 7.2 to 8.0 fails with: "Unable to complete operation on subnet <ID>. One or more ports have an IP allocation from this subnet.
rhel-osp-director: Upgrade of undercloud 7.2 to 8.0 fails with: "Unable to c...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: instack-undercloud (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
urgent Severity urgent
: ga
: 8.0 (Liberty)
Assigned To: James Slagle
Alexander Chuzhoy
: Rebase
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 15:12 EST by Alexander Chuzhoy
Modified: 2016-04-07 17:44 EDT (History)
6 users (show)

See Also:
Fixed In Version: instack-undercloud-2.2.2-1.el7ost
Doc Type: Bug Fix
Doc Text:
Running "openstack undercloud install" attempted to delete and recreate the Undercloud's neutron subnet even if the subnet required no changes. If an Overcloud was already deployed, the subnet delete attempt failed since the subnet contained allocated ports. This caused the "openstack undercloud install" command to fail. This fix changes this behavior to only attempt to delete and recreate the subnet if the "openstack undercloud install" command has a configuration change to apply to the subnet. If an Overcloud is already deployed, the same error message still occurs since the director cannot delete the subnet. This is expected behavior though since we do not recommend change the subnet's configuration with an Overcloud already deployed. However, in cases with no subnet configuration changes, the "openstack undercloud install" command no longer fails with this error message.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:44:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Chuzhoy 2016-01-06 15:12:06 EST
rhel-osp-director: Upgrade of undercloud 7.2  to 8.0 fails with: "Unable to complete operation on subnet <ID>. One or more ports have an IP allocation from this subnet.


Environment:
openstack-tripleo-heat-templates-0.8.7-2.el7ost.noarch
openstack-tripleo-0.0.7-1.el7ost.noarch
instack-undercloud-2.2.1-2.el7ost.noarch
openstack-tripleo-common-0.0.2-5.el7ost.noarch
openstack-tripleo-image-elements-0.9.7-2.el7ost.noarch
openstack-tripleo-puppet-elements-0.0.2-1.el7ost.noarch


Steps to reproduce:
1. Deploy 7.2 undercloud and HA overcloud with vxlan network backend + network isolation.
2. Attempt to upgrade the undercloud to 8.0: 
   a. Update the repos and RPMs.
   b. Run "openstack undercloud install"

Result:
+ echo 'New cidr 192.168.0.0/24 does not equal old cidr 10.19.94.0/24'
New cidr 192.168.0.0/24 does not equal old cidr 10.19.94.0/24
+ echo 'Will attempt to delete and recreate subnet 23e12754-0acd-4048-8981-59dfa94742cf
dc35b294-069a-4206-8e20-03464f9dd632
c8766472-5027-4466-b96a-e96d65f636c8
ad30e2c9-8ce8-43bf-9c00-8441328237be
43ec90c8-cdeb-4c5a-b71b-25ab1a03c6db
f273ff74-6042-4834-8a9b-8071d43f751d'
Will attempt to delete and recreate subnet 23e12754-0acd-4048-8981-59dfa94742cf
dc35b294-069a-4206-8e20-03464f9dd632
c8766472-5027-4466-b96a-e96d65f636c8
ad30e2c9-8ce8-43bf-9c00-8441328237be
43ec90c8-cdeb-4c5a-b71b-25ab1a03c6db
f273ff74-6042-4834-8a9b-8071d43f751d
+ '[' 1 -eq 1 ']'
+ grep start
+ neutron subnet-list
| ad30e2c9-8ce8-43bf-9c00-8441328237be | storage_subnet      | 10.19.95.0/24    | {"start": "10.19.95.10", "end": "10.19.95.200"}       |
| 43ec90c8-cdeb-4c5a-b71b-25ab1a03c6db | external_subnet     | 10.19.184.0/24   | {"start": "10.19.184.180", "end": "10.19.184.200"}    |
| 23e12754-0acd-4048-8981-59dfa94742cf | internal_api_subnet | 10.19.94.0/24    | {"start": "10.19.94.10", "end": "10.19.94.200"}       |
| dc35b294-069a-4206-8e20-03464f9dd632 | storage_mgmt_subnet | 192.168.200.0/24 | {"start": "192.168.200.10", "end": "192.168.200.200"} |
| c8766472-5027-4466-b96a-e96d65f636c8 | tenant_subnet       | 192.168.150.0/24 | {"start": "192.168.150.10", "end": "192.168.150.200"} |
| f273ff74-6042-4834-8a9b-8071d43f751d |                     | 192.168.0.0/24   | {"start": "192.168.0.5", "end": "192.168.0.24"}       |
++ neutron subnet-list
++ awk '{print $2}'
++ grep start
+ neutron subnet-delete c8766472-5027-4466-b96a-e96d65f636c8 ad30e2c9-8ce8-43bf-9c00-8441328237be 43ec90c8-cdeb-4c5a-b71b-25ab1a03c6db 23e12754-0acd-4048-8981-59dfa94742cf dc35b294-069a-4206-8e20-03464f9dd632 f273ff74-6042-4834-8a9b-8071d43f751d
Unable to complete operation on subnet c8766472-5027-4466-b96a-e96d65f636c8. One or more ports have an IP allocation from this subnet.
[2016-01-06 15:03:03,209] (os-refresh-config) [ERROR] during post-configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/post-configure.d']' returned non-zero exit status 1]

[2016-01-06 15:03:03,210] (os-refresh-config) [ERROR] Aborting...
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 582, in install
    _run_orc(instack_env)
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 512, in _run_orc
    _run_live_command(args, instack_env, 'os-refresh-config')
  File "/usr/lib/python2.7/site-packages/instack_undercloud/undercloud.py", line 343, in _run_live_command
    raise RuntimeError('%s failed. See log for details.' % name)
RuntimeError: os-refresh-config failed. See log for details.
Command 'instack-install-undercloud' returned non-zero exit status 1



Expected result:
Successful undercloud deployment.
Comment 1 Alexander Chuzhoy 2016-01-06 15:42:34 EST
Note:
I succeeded to upgrade the undercloud on VM setup, but then the overcloud nodes started to show the same IP on all NICs.
Please disregard if this isn't related to the reported issue.
Comment 4 Alexander Chuzhoy 2016-02-24 18:01:11 EST
Verified:
Environment:
instack-undercloud-2.2.2-2.el7ost.noarch

The reported issue doesn't reproduce.
Comment 6 errata-xmlrpc 2016-04-07 17:44:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.