Bug 1296326 - unable to delete cinder volumes after deleting instance
unable to delete cinder volumes after deleting instance
Status: CLOSED CANTFIX
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder (Show other bugs)
5.0 (RHEL 6)
Unspecified Linux
high Severity high
: ---
: 5.0 (RHEL 6)
Assigned To: Eric Harney
nlevinki
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 16:55 EST by nalmond
Modified: 2016-05-03 06:30 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-03 06:30:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nalmond 2016-01-06 16:55:04 EST
Description of problem:
About 20 instances were deleted. These instances had cinder volumes attached as boot disks. After these instances were deleted, the cinder volumes remained in the available state and cannot be deleted with cinder delete or cinder force-delete.

How reproducible:
Only happened once, new instances and volumes are unaffected

These volumes are still in this state and need to be deleted. A root cause is also needed to prevent this from happening again.
Comment 2 Eric Harney 2016-01-12 10:41:48 EST
2016-01-05 09:33:52.382 8865 ERROR cinder.volume.drivers.san.hp.hp_3par_common [req-548ce6d4-d7ac-439e-b34e-110f7cd18461 Type S, SDIRed ZSJJL8E 176a89a535bc45b4aed8fed48196caa6 - - -] Conflict (HTTP 409) 34 - resource in use
2016-01-05 09:33:52.400 8865 ERROR cinder.volume.manager [req-548ce6d4-d7ac-439e-b34e-110f7cd18461 Type S, SDIRed ZSJJL8E 176a89a535bc45b4aed8fed48196caa6 - - -] Cannot delete volume e5549d78-2b94-4cbf-ba8a-2a3002c8342d: volume is busy
Comment 10 Sergey Gotliv 2016-02-16 01:22:43 EST
Nick, any updates on this case?
Comment 14 Sergey Gotliv 2016-03-05 11:46:22 EST
Nick,

Did you escalate this issue to the HP? If not, please, do that.

Note You need to log in before you can comment on or make changes to this bug.