Bug 1296334 - Unsuccessful Errata install marked success
Unsuccessful Errata install marked success
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Errata Management (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity high (vote)
: Beta
: --
Assigned To: Katello Bug Bin
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-01-06 17:20 EST by John Mitsch
Modified: 2016-07-27 05:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:22:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13058 None None None 2016-04-22 10:54 EDT

  None (edit)
Description John Mitsch 2016-01-06 17:20:41 EST
Description of problem:

When errata is unsuccessful in installation on a host, it is still marked as success.

"""
Label: Actions::Katello::System::Erratum::Install
Name: Install erratum
Owner: admin
Started at: 2015-11-20 20:35:08 UTC
Ended at: 2015-11-20 21:02:45 UTC
State: stopped
Result: success 


 Output:

Test Transaction Errors:   installing package kernel-2.6.32-504.16.2.el6.x86_64 needs 22MB on the /boot filesystem
  installing package kernel-2.6.32-431.20.3.el6.x86_64 needs 50MB on the /boot filesystem
  installing package kernel-2.6.32-431.1.2.el6.x86_64 needs 78MB on the /boot filesystem
  installing package kernel-2.6.32-504.8.1.el6.x86_64 needs 106MB on the /boot filesystem
  installing package kernel-2.6.32-431.11.2.el6.x86_64 needs 134MB on the /boot filesystem
  installing package kernel-2.6.32-504.12.2.el6.x86_64 needs 162MB on the /boot filesystem
"""
[reply] [−]  Private Comment 6

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Set up a content host
2.Use https://jlsherrill.fedorapeople.org/fake-repos/needed-errata/ as a repo and make available to content host
3.yum install walrus-0.71 on content host
4.remove walrus 5.21 symlink from repo (on Satellite host) from /var/lib/pulp/nodes/published/https/repos/
5. Install errata on content host.

Actual results:

Errata install task is marked as success.

Expected results:

Errata install task fails or shows a warning to the user.


Additional info:

This is from https://bugzilla.redhat.com/show_bug.cgi?id=1215838 as that bug addressed both package install warnings and errata install warnings.
Comment 1 John Mitsch 2016-01-07 10:22:36 EST
Fixing this upstream is being blocked by http://projects.theforeman.org/issues/13049
Comment 2 John Mitsch 2016-01-07 15:26:56 EST
Update: This is no longer blocked by http://projects.theforeman.org/issues/13049
Comment 3 John Mitsch 2016-01-07 15:28:59 EST
Created redmine issue http://projects.theforeman.org/issues/13058 from this bug
Comment 5 Bryan Kearney 2016-02-05 14:02:02 EST
Upstream bug component is WebUI
Comment 7 Bryan Kearney 2016-03-18 12:02:14 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/13058 has been closed
-------------
John Mitsch
Applied in changeset commit:katello|1fda4ecd0b34e8f6bb6c70930c7e9502a0dceacb.
Comment 12 jcallaha 2016-04-01 16:09:36 EDT
Verified in Satellite 6.2 Beta Snap 6. Error produced when attempting to install the errata.

[u'Errors were encountered while downloading packages.', u'walrus-5.21-1.noarch: [Errno 256] No more mirrors to try.']
Comment 14 errata-xmlrpc 2016-07-27 05:22:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.