Bug 1296342 - Unable to launch CFME VM if RHEV DataCenter and Cluster Names were changed from Default: undefined method `id' for nil:NilClass app/lib/actions/fusor/deployment/rhev/cfme_launch.rb:54
Unable to launch CFME VM if RHEV DataCenter and Cluster Names were changed fr...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV (Show other bugs)
1.0
Unspecified Unspecified
unspecified Severity high
: TP2
: 1.0
Assigned To: Jason Montleon
Dave Johnson
Dan Macpherson
: Triaged
: 1296341 (view as bug list)
Depends On:
Blocks: rhci-sprint-12
  Show dependency treegraph
 
Reported: 2016-01-06 17:59 EST by John Matthews
Modified: 2016-10-03 15:09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 15:09:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tarball of /var/log/foreman (159.75 KB, application/x-gzip)
2016-01-06 18:00 EST, John Matthews
no flags Details

  None (edit)
Description John Matthews 2016-01-06 17:59:27 EST
Description of problem:

Nenad saw an issue running RHEV + CFME.
The Data Center and Cluster names were modified

Data Center:  RHCI  
Cluster:      My_Cluster


Exception:

[E] undefined method `id' for nil:NilClass (NoMethodError)
/opt/rh/ruby193/root/usr/share/gems/gems/fusor_server-0.0.1/app/lib/actions/fusor/deployment/rhev/cfme_launch.rb:54:in `
create_compute_profile'


cat /var/log/foreman/First-1/deployment.log

2016-01-05 11:45:41 [D] ====== RHEV Compute Resource run method ======
2016-01-05 11:45:44 [D] === Leaving RHEV Compute Resource run method ===
2016-01-05 11:45:44 [I] ================ Planning CFME Deployment ====================
2016-01-05 11:45:46 [I] ================ TransferImage run method ====================
2016-01-05 11:49:29 [I] ================ Leaving TransferImage run method ====================
2016-01-05 11:49:29 [I] ================ UploadImage run method ====================
2016-01-05 11:51:15 [I] image uploaded
2016-01-05 11:51:15 [I] image uploaded
2016-01-05 11:51:15 [I] ================ Leaving UploadImage run method ====================
2016-01-05 11:51:15 [I] ================ ImportTemplate run method ====================
2016-01-05 11:51:15 [I] Running: /usr/share/fusor_ovirt/bin/ovirt_import_template.py --api_user 'admin@internal' --api_pass 100yard- --api_host 192.168.0.150 --cluster_name My_Cluster --data_center_name RHCI --export_domain_name my_export --storage_domain_name my_storage --vm_template_name First-cfme-template
2016-01-05 11:53:01 [D] Status: 0, output: ["Template was imported successfully\n", "Waiting for Template to reach \"ok\" status\n"]
2016-01-05 11:53:01 [I] ================ Leaving ImportTemplate run method ====================
2016-01-05 11:53:01 [D] ====== CFME Launch run method ======



/var/log/foreman/production.log-20160106
 searched for around 11:53 and saw some exceptions

2016-01-05 11:52:47 [I] Completed 201 Created in 692ms (Views: 13.4ms | ActiveRecord: 0.6ms)
2016-01-05 11:52:48 [I] Processing by HostsController#externalNodes as YML
2016-01-05 11:52:48 [I]   Parameters: {"name"=>"hypervisor.refarch.bos.redhat.com"}
2016-01-05 11:52:48 [I]   Rendered text template (0.0ms)
2016-01-05 11:52:48 [I] Completed 200 OK in 466ms (Views: 1.0ms | ActiveRecord: 33.4ms)
2016-01-05 11:52:49 [I] Processing by Api::V2::ReportsController#create as JSON
2016-01-05 11:52:49 [I]   Parameters: {"report"=>"[FILTERED]", "apiv"=>"v2"}
2016-01-05 11:52:49 [I] processing report for hypervisor.refarch.bos.redhat.com
2016-01-05 11:52:49 [I] Imported report for hypervisor.refarch.bos.redhat.com in 0.03 seconds
2016-01-05 11:52:49 [I] Completed 201 Created in 91ms (Views: 42.8ms | ActiveRecord: 0.0ms)
2016-01-05 11:53:01 [I] ================ Leaving ImportTemplate run method ====================
2016-01-05 11:53:01 [I] Successfully decrypted field for Foreman::Model::Ovirt First-RHEV
2016-01-05 11:53:01 [E] undefined method `id' for nil:NilClass (NoMethodError)
/opt/rh/ruby193/root/usr/share/gems/gems/fusor_server-0.0.1/app/lib/actions/fusor/deployment/rhev/cfme_launch.rb:54:in `
create_compute_profile'
/opt/rh/ruby193/root/usr/share/gems/gems/fusor_server-0.0.1/app/lib/actions/fusor/deployment/rhev/cfme_launch.rb:33:in `
run'





Version-Release number of selected component (if applicable):
# rpm -qa | grep fusor
fusor-utils-0.0.1-1.el7.noarch
ruby193-rubygem-fusor_ui-0.0.1-94.el7.noarch
fusor-selinux-1.0.0-13.el7.noarch
fusor-installer-0.0.14-23.el7.noarch
ruby193-rubygem-fusor_server-0.0.1-83.el7.noarch
fusor_ovirt-0.1-11.el7.x86_64
fusor-initial-setup-0.0.21-10.el7.noarch
Comment 1 John Matthews 2016-01-06 18:00 EST
Created attachment 1112294 [details]
tarball of /var/log/foreman
Comment 2 John Matthews 2016-01-14 08:35:10 EST
*** Bug 1296341 has been marked as a duplicate of this bug. ***
Comment 3 Jason Montleon 2016-01-14 15:48:29 EST
testing a fix. We were not specifying the DC when creating the CR in Foreman, meaning we always used Default.
Comment 4 Jason Montleon 2016-01-14 16:08:04 EST
https://github.com/fusor/fusor/pull/628
Comment 5 Antonin Pagac 2016-02-03 07:51:45 EST
Renamed both DataCenter and Cluster and saw a successful RHEV deployment. Marking as verified.

RHCI-6.0-RHEL-7-20160201.0-RHCI-x86_64-dvd1.iso
Comment 6 Antonin Pagac 2016-02-03 10:15:59 EST
When I wrote 'successful RHEV deployment' I meant 'successful RHEV+CFME deployment'.

Note You need to log in before you can comment on or make changes to this bug.