Bug 129635 - kernel 2.6.7-1.503 and later panic on startup
kernel 2.6.7-1.503 and later panic on startup
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
powerpc Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
Depends On:
Blocks: fedora-ppc FC3Target
  Show dependency treegraph
 
Reported: 2004-08-11 04:08 EDT by Alex Kiernan
Modified: 2007-11-30 17:10 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-19 07:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alex Kiernan 2004-08-11 04:08:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803 Epiphany/1.2.7

Description of problem:
On startup -503 and -509 (the two I've tried) panic on startup:

exec of init failed!!!!: 14
Kernel Panic: Attemped to kill init!
Rebooting in 180 Secs.

-501 was okay.

Problem seems to be hardware specific - it fails on an early blue &
white G4. /proc/cpuinfo has:

processor       : 0
cpu             : 7400, altivec supported
temperature     : 36 C (uncalibrated)
clock           : 450MHz
revision        : 2.8 (pvr 000c 0208)
bogomips        : 894.97
machine         : PowerMac3,1
motherboard     : PowerMac3,1 MacRISC Power Macintosh
detected as     : 65 (PowerMac G4 AGP Graphics)
pmac flags      : 00000004
L2 cache        : 1024K unified
memory          : 384MB
pmac-generation : NewWorld

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install -503 or -509
2. Reboot
3.
    

Additional info:
Comment 1 Paul Nasrat 2004-08-11 04:47:15 EDT
What version of mkinitrd are you using?  Talking with dwmw2 seems to
think it's mkinitrd-4.0.0-1 specific.  Can you roll back mkinitrd and
regenerate the initrd and confirm that it will boot.
Comment 2 Alex Kiernan 2004-08-11 04:48:52 EDT
Rolling back to mkinitrd-3.5.22-1 and rebuilding the initrd does fix
the problem.
Comment 3 Paul Nasrat 2004-08-11 05:08:41 EDT
Assign to owner
Comment 4 Paul Nasrat 2004-08-11 06:28:55 EDT
Can you check rebuilding initrd with current rawhide mkinitrd-4.0.2-1
also.
Comment 5 Alex Kiernan 2004-08-11 08:32:23 EDT
Switching to mkinitrd-4.0.2-1.ppc it crashes as before.
Comment 6 Guy Streeter 2004-08-11 10:29:41 EDT
I think it's something wrong with using root=LABEL=/ commandline
option and the new mkinitrd. Can you try it with root= your real root
device/partition? That fixed a similar failure for me.
Comment 7 Jeremy Katz 2004-08-11 11:31:49 EDT
Can you also remove quiet from your boot params and give all of the
output after "Red Hat nash version 4.... starting"?
Comment 8 Alex Kiernan 2004-08-11 11:40:19 EDT
Moving back to 4.0.2-1, changing yaboot.conf to have root=/dev/sda3,
running ybin & rebuilding the initrd, it still panics on startup.

Looking a bit more closely, it looks like the filesystem which
mkinitrd is generating isn't a filesystem... If I gunzip one generated
by 3.5.22 (-501) and one generated by 4.0.2 (-509):

initrd-2.6.7-1.501: Linux rev 1.0 ext2 filesystem data
initrd-2.6.7-1.509: ASCII cpio archive (SVR4 with no CRC)

Looking at initrd-2.6.7-1.509, it does indeed appear to be cpio archive.
Comment 9 Jeremy Katz 2004-08-11 11:42:32 EDT
Yes, they're intentionally cpio archives now and not a filesystem.  

Technically, it's an initramfs now and not an initrd.  Lalala... pay
no attention to the man behind the curtain
Comment 10 Alex Kiernan 2004-08-11 12:23:41 EDT
Okay :)

I don't actually have any quiets on any of my startup stuff though...

If I remove all the `--quiet's from mkinitrd, I get:

(running in test mode).
Red Hat nash version 4.0.2 starting
No module scsi_transport_spi found for kernel 2.6.7-1.509, aborting.

But I'm not sure thats the same problem (having hacked it like that,
it $? = 1, rather than 0 which is what I get from /sbin/mkinitrd)
Comment 11 Alex Kiernan 2004-08-11 12:27:15 EDT
In fact, I'm sure that error's bogus... I just don't understand why.
Comment 12 Alex Kiernan 2004-08-11 12:40:21 EDT
Its just occurred to me it may not be clear where this is happening in
the startup process - nash has been started as init & has got all the
way to the end of its script & is trying to switch the root across to
the real root - "Switching to new root".
Comment 13 Jeremy Katz 2004-08-11 15:57:58 EDT
Could you try again with mkinitrd 4.0.4 (will be at
http://people.redhat.com/~katzj/mkinitrd/ as soon as it's done building)?
Comment 14 Alex Kiernan 2004-08-11 21:12:04 EDT
Will do, though I'm not going to be back near the machine in question 
for about a week - sorry.
Comment 15 David Woodhouse 2004-08-12 09:34:00 EDT
4.0.4-1 doesn't fix it for me. 
Comment 16 James Laska 2004-08-12 09:45:58 EDT
concur with dwmw2's comment#15 ... with 515 kernel still getting panic
on can't find init

switchroot : mount failed : 22
Comment 17 Sammy 2004-08-12 11:14:50 EDT
I can confirm this with  mkinitrd-4.0.4-1 and kernel-2.6.7-1.517. 
Comment 18 Jeremy Katz 2004-08-12 13:54:28 EDT
Oops, I suck. 

4.0.5 is up in the same place and really should fix it (I've tested it
as well as erikj this time :)
Comment 19 Alex Kiernan 2004-08-19 07:46:28 EDT
This is working fine for me know w/ mkinitrd-4.0.6-1

Note You need to log in before you can comment on or make changes to this bug.